summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-05-29 17:22:23 +0200
committergregor herrmann <gregoa@debian.org>2020-05-29 17:22:23 +0200
commit83159deddd08719406022971f781f9baaa1e16ea (patch)
treed00291d930adb3ba9a77922da4e074386ab84d48
parent5e57c9c826b23bdf77a0c405e0c1fdaf234eacf3 (diff)
New upstream version 1.52
-rw-r--r--Build.PL7
-rw-r--r--CHANGES3
-rw-r--r--META.yml4
-rw-r--r--Makefile.PL32
-rw-r--r--lib/Config/File.pm4
5 files changed, 13 insertions, 37 deletions
diff --git a/Build.PL b/Build.PL
index f9a59c3..432779f 100644
--- a/Build.PL
+++ b/Build.PL
@@ -11,7 +11,12 @@ my $build = Module::Build->new(
Test::Pod::Coverage => 0,
Module::Build => 0
},
-
+ meta_merge => {
+ resources => {
+ homepage => 'http://github.com/stockholmuniversity/Config-File',
+ repository => 'git://github.com/stockholmuniversity/Config-File.git'
+ },
+ },
create_makefile_pl => 'passthrough'
);
$build->create_build_script;
diff --git a/CHANGES b/CHANGES
index 34d7cb8..b6d91c6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,4 +1,7 @@
UNRELEASED
+1.52 (15-Nov-2018):
+ - Less problematic build CPAN RT#132165
+
1.51 (15-Nov-2018):
- Fix old bugs from CPAN RT
- perltidy
diff --git a/META.yml b/META.yml
index 8b39fa5..670923c 100644
--- a/META.yml
+++ b/META.yml
@@ -1,6 +1,6 @@
---
name: Config-File
-version: 1.51
+version: 1.52
author:
- 'Gunnar Wolf <gwolf@gwolf.org>'
abstract: Parse a simple configuration file
@@ -14,7 +14,7 @@ build_requires:
provides:
Config::File:
file: lib/Config/File.pm
- version: 1.51
+ version: 1.52
generated_by: Module::Build version 0.280801
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.2.html
diff --git a/Makefile.PL b/Makefile.PL
deleted file mode 100644
index 64370ac..0000000
--- a/Makefile.PL
+++ /dev/null
@@ -1,32 +0,0 @@
- # Note: this file was auto-generated by Module::Build::Compat version 0.2808_01
-
- unless ( eval "use Module::Build::Compat 0.02; 1" ) {
- print "This module requires Module::Build to install itself.\n";
-
- require ExtUtils::MakeMaker;
- my $yn =
- ExtUtils::MakeMaker::prompt( ' Install Module::Build now from CPAN?',
- 'y' );
-
- unless ( $yn =~ /^y/i ) {
- die " *** Cannot install without Module::Build. Exiting ...\n";
- }
-
- require Cwd;
- require File::Spec;
- require CPAN;
-
- # Save this 'cause CPAN will chdir all over the place.
- my $cwd = Cwd::cwd();
-
- CPAN::Shell->install('Module::Build::Compat');
- CPAN::Shell->expand( "Module", "Module::Build::Compat" )->uptodate
- or die "Couldn't install Module::Build, giving up.\n";
-
- chdir $cwd or die "Cannot chdir() back to $cwd: $!";
- }
- eval "use Module::Build::Compat 0.02; 1" or die $@;
-
- Module::Build::Compat->run_build_pl( args => \@ARGV );
- require Module::Build;
- Module::Build::Compat->write_makefile( build_class => 'Module::Build' );
diff --git a/lib/Config/File.pm b/lib/Config/File.pm
index 41cb311..c8a0835 100644
--- a/lib/Config/File.pm
+++ b/lib/Config/File.pm
@@ -8,7 +8,7 @@ use IO::File;
use vars qw($VERSION @ISA @EXPORT_OK);
@ISA = qw/Exporter/;
@EXPORT_OK = qw/read_config_file/;
-$VERSION = '1.51';
+$VERSION = '1.52';
sub read_config_file($) {
my ( $conf, $file, $fh, $line_num );
@@ -169,7 +169,7 @@ it and/or modify it under the terms of the GPL.
=head1 VERSION
-Version 1.4
+Version 1.52
Copyright (c) 2002 Sebastien J. Gross. All rights reserved.
Copyright (c) 2003-2009 Gunnar Wolf. All rights reserved.
This program is free software; you can redistribute it and/or modify