summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2022-03-13 18:34:55 +0100
committergregor herrmann <gregoa@debian.org>2022-03-13 18:34:55 +0100
commit62fa9842782633eedd8c4e71c348b7566b1c3d4a (patch)
tree656477361ae1bd31a478a60db27aa383ebeab6b2
parent4924e737a78852e7f9b60e66f6815598bc05b7ca (diff)
Use ExtUtils::PkgConfig instead of the unpackaged Crypt::OpenSSL::Guess.archive/debian/0.18-1
Origin: vendor Forwarded: not-needed Last-Update: 2022-03-13 Gbp-Pq: Name no_crypt-openssl-guess.patch
-rwxr-xr-xMakefile.PL7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4a6a95f..f6a106c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,6 +1,7 @@
use 5.008000;
use ExtUtils::MakeMaker;
-use Crypt::OpenSSL::Guess qw(openssl_inc_paths openssl_lib_paths);
+use ExtUtils::PkgConfig;
+%pkg_info = ExtUtils::PkgConfig->find ('libcrypto');
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
WriteMakefile(
@@ -10,9 +11,9 @@ WriteMakefile(
($] >= 5.005 ? ## Add these new keywords supported since 5.005
(ABSTRACT_FROM => 'PKCS10.pm',
AUTHOR => 'JoNO <jonozzz@yahoo.com>') : ()),
- LIBS => [openssl_lib_paths().' -lcrypto'],
+ LIBS => [$pkg_info{libs}],
DEFINE => '-DPERL5 -Wall',
- INC => openssl_inc_paths(),
+ INC => $pkg_info{cflags},
'dist' => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
'clean' => { FILES => 'Crypt-OpenSSL-PKCS10-*' },