summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Carvalho <smash@cpan.org>2019-08-10 09:21:15 +0200
committerUtkarsh Gupta <guptautkarsh2102@gmail.com>2019-08-10 09:21:15 +0200
commit39d830444ce7f11e1c0b05e9582844afa9a81541 (patch)
tree6608a8ce76de5eb919690389a84433e3b216308f
parent226da9f7836de74021869e9520e220f81a9377e3 (diff)
remove required version for ExtUtils::MakeMaker, this is only
Forwarded: not-needed Reviewed-by: gregor herrmann <gregoa@debian.org> Last-Update: 2019-08-10 required to avoid YAML version 1.16 which is not packaged for debian Gbp-Pq: Name remove-eumm-version-req.patch
-rw-r--r--META.json6
-rw-r--r--META.yml4
-rw-r--r--Makefile.PL10
3 files changed, 10 insertions, 10 deletions
diff --git a/META.json b/META.json
index 1dbe2bf8..d44ec378 100644
--- a/META.json
+++ b/META.json
@@ -16,14 +16,14 @@
"prereqs" : {
"build" : {
"requires" : {
- "ExtUtils::MakeMaker" : "7.1101",
+ "ExtUtils::MakeMaker" : "0",
"Test::CPAN::Meta" : "0"
}
},
"configure" : {
"requires" : {
"CPAN::Meta::Requirements" : "2.120620",
- "ExtUtils::MakeMaker" : "7.1101",
+ "ExtUtils::MakeMaker" : "0",
"File::ShareDir::Install" : "0.06",
"Module::Metadata" : "0"
}
@@ -125,7 +125,7 @@
},
"requires" : {
"Capture::Tiny" : "0.12",
- "ExtUtils::MakeMaker" : "7.1101",
+ "ExtUtils::MakeMaker" : "0",
"File::Spec" : "0",
"HTTP::Cookies" : "0",
"HTTP::Headers" : "0",
diff --git a/META.yml b/META.yml
index b4cbc6c2..4d11d857 100644
--- a/META.yml
+++ b/META.yml
@@ -4,7 +4,7 @@ author:
- 'Dancer Core Developers'
build_requires:
Capture::Tiny: '0.12'
- ExtUtils::MakeMaker: '7.1101'
+ ExtUtils::MakeMaker: '0'
File::Spec: '0'
HTTP::Cookies: '0'
HTTP::Headers: '0'
@@ -18,7 +18,7 @@ build_requires:
Test::More: '0.92'
configure_requires:
CPAN::Meta::Requirements: '2.120620'
- ExtUtils::MakeMaker: '7.1101'
+ ExtUtils::MakeMaker: '0'
File::ShareDir::Install: '0.06'
Module::Metadata: '0'
conflicts:
diff --git a/Makefile.PL b/Makefile.PL
index 4c3577a3..2c596feb 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,7 +4,7 @@ use warnings;
-use ExtUtils::MakeMaker 7.1101;
+use ExtUtils::MakeMaker;
use File::ShareDir::Install;
$File::ShareDir::Install::INCLUDE_DOTFILES = 1;
@@ -16,12 +16,12 @@ my %WriteMakefileArgs = (
"ABSTRACT" => "Lightweight yet powerful web application framework",
"AUTHOR" => "Dancer Core Developers",
"BUILD_REQUIRES" => {
- "ExtUtils::MakeMaker" => "7.1101",
+ "ExtUtils::MakeMaker" => "0",
"Test::CPAN::Meta" => 0
},
"CONFIGURE_REQUIRES" => {
"CPAN::Meta::Requirements" => "2.120620",
- "ExtUtils::MakeMaker" => "7.1101",
+ "ExtUtils::MakeMaker" => "0",
"File::ShareDir::Install" => "0.06",
"Module::Metadata" => 0
},
@@ -81,7 +81,7 @@ my %WriteMakefileArgs = (
},
"TEST_REQUIRES" => {
"Capture::Tiny" => "0.12",
- "ExtUtils::MakeMaker" => "7.1101",
+ "ExtUtils::MakeMaker" => "0",
"File::Spec" => 0,
"HTTP::Cookies" => 0,
"HTTP::Headers" => 0,
@@ -111,7 +111,7 @@ my %FallbackPrereqs = (
"Encode" => 0,
"Exporter" => "5.57",
"Exporter::Tiny" => 0,
- "ExtUtils::MakeMaker" => "7.1101",
+ "ExtUtils::MakeMaker" => "0",
"File::Basename" => 0,
"File::Copy" => 0,
"File::Find" => 0,