summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2014-06-27 03:25:06 +0200
committergregor herrmann <gregoa@debian.org>2014-06-27 03:25:06 +0200
commit899067f8e7f4ccbff596d792428a05ff5faa5578 (patch)
treec706276c5dd51374693d31e9aab59bee3de57a6b
parentcaa32e654cb5ca31bf8c82504d7882b81a4134b5 (diff)
parent2e3852a533b81e26978e3f6eb2a037eb53b46c59 (diff)
Merge tag 'upstream/0.002009'
Upstream version 0.002009
-rw-r--r--Changes3
-rw-r--r--MANIFEST1
-rw-r--r--META.json3
-rw-r--r--META.yml2
-rw-r--r--Makefile.PL2
-rw-r--r--README2
-rw-r--r--README.mkdn2
-rw-r--r--dist.ini3
-rw-r--r--lib/Data/Perl.pm4
-rw-r--r--lib/Data/Perl/Bool.pm4
-rw-r--r--lib/Data/Perl/Code.pm4
-rw-r--r--lib/Data/Perl/Collection/Array.pm4
-rw-r--r--lib/Data/Perl/Collection/Hash.pm4
-rw-r--r--lib/Data/Perl/Counter.pm4
-rw-r--r--lib/Data/Perl/Number.pm4
-rw-r--r--lib/Data/Perl/Role/Bool.pm12
-rw-r--r--lib/Data/Perl/Role/Code.pm8
-rw-r--r--lib/Data/Perl/Role/Collection/Array.pm72
-rw-r--r--lib/Data/Perl/Role/Collection/Hash.pm4
-rw-r--r--lib/Data/Perl/Role/Counter.pm16
-rw-r--r--lib/Data/Perl/Role/Number.pm16
-rw-r--r--lib/Data/Perl/Role/String.pm4
-rw-r--r--lib/Data/Perl/String.pm4
-rw-r--r--t/release-pod-syntax.t14
24 files changed, 108 insertions, 88 deletions
diff --git a/Changes b/Changes
index f85bcf8..abdeee0 100644
--- a/Changes
+++ b/Changes
@@ -1,3 +1,6 @@
+0.002009 2014-06-26 21:04:12EDT-0400 America/Toronto
+ - fixes pod test failures. thanks gregor herrmann / Debian perl team!
+
0.002008 2014-06-25 11:37:43EDT-0400 America/Toronto
0.002007 2013-05-19 22:22:25 America/Toronto
diff --git a/MANIFEST b/MANIFEST
index 74b58c1..6dcd33f 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -32,4 +32,5 @@ t/counter.t
t/helpers.t
t/number.t
t/release-pod-coverage.t
+t/release-pod-syntax.t
t/string.t
diff --git a/META.json b/META.json
index 24e4bb0..d8bf3fb 100644
--- a/META.json
+++ b/META.json
@@ -22,6 +22,7 @@
"develop" : {
"requires" : {
"Pod::Coverage::TrustPod" : "0",
+ "Test::Pod" : "1.41",
"Test::Pod::Coverage" : "1.08"
}
},
@@ -57,6 +58,6 @@
"web" : "https://github.com/mattp-/Data-Perl"
}
},
- "version" : "0.002008"
+ "version" : "0.002009"
}
diff --git a/META.yml b/META.yml
index 55597e2..d06422b 100644
--- a/META.yml
+++ b/META.yml
@@ -28,4 +28,4 @@ resources:
bugtracker: https://github.com/mattp-/Data-Perl/issues
homepage: https://github.com/mattp-/Data-Perl
repository: https://github.com/mattp-/Data-Perl.git
-version: 0.002008
+version: 0.002009
diff --git a/Makefile.PL b/Makefile.PL
index 7e52135..9621c30 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -34,7 +34,7 @@ my %WriteMakefileArgs = (
"Test::Fatal" => 0,
"Test::Output" => 0
},
- "VERSION" => "0.002008",
+ "VERSION" => "0.002009",
"test" => {
"TESTS" => "t/*.t t/collection/*.t"
}
diff --git a/README b/README
index 4195a42..86ad5c0 100644
--- a/README
+++ b/README
@@ -2,7 +2,7 @@ NAME
Data::Perl - Base classes wrapping fundamental Perl data types.
VERSION
- version 0.002008
+ version 0.002009
SYNOPSIS
use Data::Perl;
diff --git a/README.mkdn b/README.mkdn
index f04db5f..eb090b8 100644
--- a/README.mkdn
+++ b/README.mkdn
@@ -4,7 +4,7 @@ Data::Perl - Base classes wrapping fundamental Perl data types.
# VERSION
-version 0.002008
+version 0.002009
# SYNOPSIS
diff --git a/dist.ini b/dist.ini
index db3dd64..1385e7e 100644
--- a/dist.ini
+++ b/dist.ini
@@ -2,7 +2,7 @@ name = Data-Perl
author = Matthew Phillips <mattp@cpan.org>
license = Perl_5
copyright_holder = Matthew Phillips <mattp@cpan.org>
-version = 0.002008
+version = 0.002009
[@Basic]
@@ -26,6 +26,7 @@ issues = 1
[ReadmeFromPod]
[ReadmeMarkdownFromPod]
[PodCoverageTests]
+[PodSyntaxTests]
[Prereqs / RuntimeRequires]
strictures = 0
diff --git a/lib/Data/Perl.pm b/lib/Data/Perl.pm
index 6692c38..bddb868 100644
--- a/lib/Data/Perl.pm
+++ b/lib/Data/Perl.pm
@@ -1,5 +1,5 @@
package Data::Perl;
-$Data::Perl::VERSION = '0.002008';
+$Data::Perl::VERSION = '0.002009';
# ABSTRACT: Base classes wrapping fundamental Perl data types.
BEGIN {
@@ -44,7 +44,7 @@ Data::Perl - Base classes wrapping fundamental Perl data types.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Bool.pm b/lib/Data/Perl/Bool.pm
index 32a2d6a..169b333 100644
--- a/lib/Data/Perl/Bool.pm
+++ b/lib/Data/Perl/Bool.pm
@@ -1,5 +1,5 @@
package Data::Perl::Bool;
-$Data::Perl::Bool::VERSION = '0.002008';
+$Data::Perl::Bool::VERSION = '0.002009';
# ABSTRACT: Wrapping class for boolean values.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Bool - Wrapping class for boolean values.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Code.pm b/lib/Data/Perl/Code.pm
index 6ace313..2b73e7c 100644
--- a/lib/Data/Perl/Code.pm
+++ b/lib/Data/Perl/Code.pm
@@ -1,5 +1,5 @@
package Data::Perl::Code;
-$Data::Perl::Code::VERSION = '0.002008';
+$Data::Perl::Code::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl coderefs.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Code - Wrapping class for Perl coderefs.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Collection/Array.pm b/lib/Data/Perl/Collection/Array.pm
index c057e2d..47daf36 100644
--- a/lib/Data/Perl/Collection/Array.pm
+++ b/lib/Data/Perl/Collection/Array.pm
@@ -1,5 +1,5 @@
package Data::Perl::Collection::Array;
-$Data::Perl::Collection::Array::VERSION = '0.002008';
+$Data::Perl::Collection::Array::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl's built in array structure.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Collection::Array - Wrapping class for Perl's built in array structu
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Collection/Hash.pm b/lib/Data/Perl/Collection/Hash.pm
index 6a9f359..513325e 100644
--- a/lib/Data/Perl/Collection/Hash.pm
+++ b/lib/Data/Perl/Collection/Hash.pm
@@ -1,5 +1,5 @@
package Data::Perl::Collection::Hash;
-$Data::Perl::Collection::Hash::VERSION = '0.002008';
+$Data::Perl::Collection::Hash::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl's built in hash structure.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Collection::Hash - Wrapping class for Perl's built in hash structure
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Counter.pm b/lib/Data/Perl/Counter.pm
index b5b47a6..9037507 100644
--- a/lib/Data/Perl/Counter.pm
+++ b/lib/Data/Perl/Counter.pm
@@ -1,5 +1,5 @@
package Data::Perl::Counter;
-$Data::Perl::Counter::VERSION = '0.002008';
+$Data::Perl::Counter::VERSION = '0.002009';
# ABSTRACT: Wrapping class for a simple numeric counter.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Counter - Wrapping class for a simple numeric counter.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Number.pm b/lib/Data/Perl/Number.pm
index 66720b0..6747b51 100644
--- a/lib/Data/Perl/Number.pm
+++ b/lib/Data/Perl/Number.pm
@@ -1,5 +1,5 @@
package Data::Perl::Number;
-$Data::Perl::Number::VERSION = '0.002008';
+$Data::Perl::Number::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl scalar numbers.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::Number - Wrapping class for Perl scalar numbers.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Role/Bool.pm b/lib/Data/Perl/Role/Bool.pm
index 7b8d496..6606b20 100644
--- a/lib/Data/Perl/Role/Bool.pm
+++ b/lib/Data/Perl/Role/Bool.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Bool;
-$Data::Perl::Role::Bool::VERSION = '0.002008';
+$Data::Perl::Role::Bool::VERSION = '0.002009';
# ABSTRACT: Wrapping class for boolean values.
use strictures 1;
@@ -28,7 +28,7 @@ Data::Perl::Role::Bool - Wrapping class for boolean values.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
@@ -55,21 +55,21 @@ None of these methods accept arguments.
Constructs a new Data::Perl::Collection::Bool object initialized with the passed
in value, and returns it.
-=item * B<set>
+=item B<set>
Sets the value to C<1> and returns C<1>.
-=item * B<unset>
+=item B<unset>
Set the value to C<0> and returns C<0>.
-=item * B<toggle>
+=item B<toggle>
Toggles the value. If it's true, set to false, and vice versa.
Returns the new value.
-=item * B<not>
+=item B<not>
Equivalent of 'not C<$value>'.
diff --git a/lib/Data/Perl/Role/Code.pm b/lib/Data/Perl/Role/Code.pm
index 95dbeb3..6e9d203 100644
--- a/lib/Data/Perl/Role/Code.pm
+++ b/lib/Data/Perl/Role/Code.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Code;
-$Data::Perl::Role::Code::VERSION = '0.002008';
+$Data::Perl::Role::Code::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl coderefs.
use strictures 1;
@@ -25,7 +25,7 @@ Data::Perl::Role::Code - Wrapping class for Perl coderefs.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
@@ -48,11 +48,11 @@ This class provides a wrapper and methods for interacting with Perl coderefs.
Constructs a new Data::Perl::Code object, initialized to $coderef as passed in,
and returns it.
-=item * B<execute(@args)>
+=item B<execute(@args)>
Calls the coderef with the given args.
-=item * B<execute_method(@args)>
+=item B<execute_method(@args)>
Calls the coderef with the the instance as invocant and given args. B<This is
currently disabled and triggers a die due to implementation details yet to be
diff --git a/lib/Data/Perl/Role/Collection/Array.pm b/lib/Data/Perl/Role/Collection/Array.pm
index 9e1558a..fe1dee4 100644
--- a/lib/Data/Perl/Role/Collection/Array.pm
+++ b/lib/Data/Perl/Role/Collection/Array.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Collection::Array;
-$Data::Perl::Role::Collection::Array::VERSION = '0.002008';
+$Data::Perl::Role::Collection::Array::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl's built in array structure.
use strictures 1;
@@ -198,7 +198,7 @@ Data::Perl::Role::Collection::Array - Wrapping class for Perl's built in array s
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
@@ -224,7 +224,7 @@ All methods that return a list do so via a Data::Perl::Collection::Array object.
Constructs a new Data::Perl::Collection::Array object initialized with passed
in values, and returns it.
-=item * B<count>
+=item B<count>
Returns the number of elements in the array.
@@ -234,7 +234,7 @@ Returns the number of elements in the array.
This method does not accept any arguments.
-=item * B<is_empty>
+=item B<is_empty>
Returns a boolean value that is true when the array has no elements.
@@ -242,7 +242,7 @@ Returns a boolean value that is true when the array has no elements.
This method does not accept any arguments.
-=item * B<elements/all>
+=item B<elements/all>
Returns all of the elements of the array as an array (not an array reference).
@@ -251,7 +251,7 @@ Returns all of the elements of the array as an array (not an array reference).
This method does not accept any arguments.
-=item * B<get($index)>
+=item B<get($index)>
Returns an element of the array by its index. You can also use negative index
numbers, just as with Perl's core array handling.
@@ -263,33 +263,33 @@ If the specified element does not exist, this will return C<undef>.
This method accepts just one argument.
-=item * B<pop>
+=item B<pop>
Just like Perl's builtin C<pop>.
This method does not accept any arguments.
-=item * B<push($value1, $value2, value3 ...)>
+=item B<push($value1, $value2, value3 ...)>
Just like Perl's builtin C<push>. Returns the number of elements in the new
array.
This method accepts any number of arguments.
-=item * B<shift>
+=item B<shift>
Just like Perl's builtin C<shift>.
This method does not accept any arguments.
-=item * B<unshift($value1, $value2, value3 ...)>
+=item B<unshift($value1, $value2, value3 ...)>
Just like Perl's builtin C<unshift>. Returns the number of elements in the new
array.
This method accepts any number of arguments.
-=item * B<splice($offset, $length, @values)>
+=item B<splice($offset, $length, @values)>
Just like Perl's builtin C<splice>. In scalar context, this returns the last
element removed, or C<undef> if no elements were removed. In list context, this
@@ -298,7 +298,7 @@ object.
This method requires at least one argument.
-=item * B<first( sub { ... } )>
+=item B<first( sub { ... } )>
This method returns the first matching item in the array, just like
L<List::Util>'s C<first> function. The matching is done with a subroutine
@@ -310,7 +310,7 @@ element in the array until one matches or all elements have been checked.
This method requires a single argument.
-=item * B<first_index( sub { ... } )>
+=item B<first_index( sub { ... } )>
This method returns the index of the first matching item in the array, just
like L<List::MoreUtils>'s C<first_index> function. The matching is done with a
@@ -320,7 +320,7 @@ checked.
This method requires a single argument.
-=item * B<grep( sub { ... } )>
+=item B<grep( sub { ... } )>
This method returns every element matching a given criteria, just like Perl's
core C<grep> function. This method requires a subroutine which implements the
@@ -331,7 +331,7 @@ matching logic. The returned list is provided as a Collection::Array object.
This method requires a single argument.
-=item * B<map( sub { ... } )>
+=item B<map( sub { ... } )>
This method transforms every element in the array and returns a new array, just
like Perl's core C<map> function. This method requires a subroutine which
@@ -343,7 +343,7 @@ a Collection::Array object.
This method requires a single argument.
-=item * B<reduce( sub { ... } )>
+=item B<reduce( sub { ... } )>
This method turns an array into a single value, by passing a function the
value so far and the next value in the array, just like L<List::Util>'s
@@ -355,9 +355,9 @@ to this method.
This method requires a single argument.
-=item * B<sort>
+=item B<sort>
-=item * B<sort( sub { ... } )>
+=item B<sort( sub { ... } )>
Returns the elements of the array in sorted order.
@@ -375,9 +375,9 @@ is provided as a Collection::Array object.
This method accepts a single argument.
-=item * B<sort_in_place>
+=item B<sort_in_place>
-=item * B<sort_in_place( sub { ... } )>
+=item B<sort_in_place( sub { ... } )>
Sorts the array I<in place>, modifying the value of the attribute.
@@ -388,28 +388,28 @@ as a Collection::Array object.
This method accepts a single argument.
-=item * B<reverse>
+=item B<reverse>
Returns the elements of the array in reversed order. The returned list is
provided as a Collection::Array object.
This method does not accept any arguments.
-=item * B<shuffle>
+=item B<shuffle>
Returns the elements of the array in random order, like C<shuffle> from
L<List::Util>. The returned list is provided as a Collection::Array object.
This method does not accept any arguments.
-=item * B<uniq>
+=item B<uniq>
Returns the array with all duplicate elements removed, like C<uniq> from
L<List::MoreUtils>. The returned list is provided as a Collection::Array object.
This method does not accept any arguments.
-=item * B<join($str)>
+=item B<join($str)>
Joins every element of the array using the separator given as argument, just
like Perl's core C<join> function.
@@ -419,14 +419,14 @@ like Perl's core C<join> function.
This method requires a single argument.
-=item * B<print($handle, $str)>
+=item B<print($handle, $str)>
Prints the output of join($str) to $handle. $handle defaults to STDOUT, and
join $str defaults to join()'s default of ','.
$joined = $stuff->print(*STDERR, ';'); # prints foo;bar;baz to STDERR
-=item * B<set($index, $value)>
+=item B<set($index, $value)>
Given an index and a value, sets the specified array element's value.
@@ -434,7 +434,7 @@ This method returns the value at C<$index> after the set.
This method requires two arguments.
-=item * B<delete($index)>
+=item B<delete($index)>
Removes the element at the given index from the array.
@@ -445,7 +445,7 @@ return C<undef>.
This method requires one argument.
-=item * B<insert($index, $value)>
+=item B<insert($index, $value)>
Inserts a new element into the array at the given index.
@@ -454,7 +454,7 @@ dependent on splice context semantics.
This method requires two arguments.
-=item * B<clear>
+=item B<clear>
Empties the entire array, like C<@array = ()>.
@@ -462,9 +462,9 @@ This method does not define a return value.
This method does not accept any arguments.
-=item * B<accessor($index)>
+=item B<accessor($index)>
-=item * B<accessor($index, $value)>
+=item B<accessor($index, $value)>
This method provides a get/set accessor for the array, based on array indexes.
If passed one argument, it returns the value at the specified index. If
@@ -474,9 +474,9 @@ When called as a setter, this method returns the new value at C<$index>.
This method accepts one or two arguments.
-=item * B<natatime($n)>
+=item B<natatime($n)>
-=item * B<natatime($n, $code)>
+=item B<natatime($n, $code)>
This method returns an iterator which, on each call, returns C<$n> more items
from the array, in order, like C<natatime> from L<List::MoreUtils>. A coderef
@@ -485,19 +485,19 @@ in the array.
This method accepts one or two arguments.
-=item * B<shallow_clone>
+=item B<shallow_clone>
This method returns a shallow clone of the array reference. The return value
is a reference to a new array with the same elements. It is I<shallow>
because any elements that were references in the original will be the I<same>
references in the clone.
-=item * B<flatten>
+=item B<flatten>
This method returns a list of elements in the array. This method is an alias
to the I<elements> method.
-=item * B<flatten_deep($level)>
+=item B<flatten_deep($level)>
This method returns a flattened list of elements in the array. Will flatten
arrays contained within the root array recursively - depth is controlled by the
diff --git a/lib/Data/Perl/Role/Collection/Hash.pm b/lib/Data/Perl/Role/Collection/Hash.pm
index d66f56e..967a997 100644
--- a/lib/Data/Perl/Role/Collection/Hash.pm
+++ b/lib/Data/Perl/Role/Collection/Hash.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Collection::Hash;
-$Data::Perl::Role::Collection::Hash::VERSION = '0.002008';
+$Data::Perl::Role::Collection::Hash::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl's built in hash structure.
use strictures 1;
@@ -116,7 +116,7 @@ Data::Perl::Role::Collection::Hash - Wrapping class for Perl's built in hash str
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/Role/Counter.pm b/lib/Data/Perl/Role/Counter.pm
index 0f3c51b..dbbdd46 100644
--- a/lib/Data/Perl/Role/Counter.pm
+++ b/lib/Data/Perl/Role/Counter.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Counter;
-$Data::Perl::Role::Counter::VERSION = '0.002008';
+$Data::Perl::Role::Counter::VERSION = '0.002009';
# ABSTRACT: Wrapping class for a simple numeric counter.
use strictures 1;
@@ -26,7 +26,7 @@ Data::Perl::Role::Counter - Wrapping class for a simple numeric counter.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
@@ -51,31 +51,31 @@ This class provides a wrapper and methods for a simple numeric counter.
Constructs a new Data::Perl::Collection::Counter object initialized with the passed
in value, and returns it.
-=item * B<set($value)>
+=item B<set($value)>
Sets the counter to the specified value and returns the new value.
This method requires a single argument.
-=item * B<inc>
+=item B<inc>
-=item * B<inc($arg)>
+=item B<inc($arg)>
Increases the attribute value by the amount of the argument, or by 1 if no
argument is given. This method returns the new value.
This method accepts a single argument.
-=item * B<dec>
+=item B<dec>
-=item * B<dec($arg)>
+=item B<dec($arg)>
Decreases the attribute value by the amount of the argument, or by 1 if no
argument is given. This method returns the new value.
This method accepts a single argument.
-=item * B<reset>
+=item B<reset>
Resets the value stored in this slot to its default value, and returns the new
value.
diff --git a/lib/Data/Perl/Role/Number.pm b/lib/Data/Perl/Role/Number.pm
index 5b0fa74..66e670c 100644
--- a/lib/Data/Perl/Role/Number.pm
+++ b/lib/Data/Perl/Role/Number.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::Number;
-$Data::Perl::Role::Number::VERSION = '0.002008';
+$Data::Perl::Role::Number::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl scalar numbers.
use strictures 1;
@@ -32,7 +32,7 @@ Data::Perl::Role::Number - Wrapping class for Perl scalar numbers.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
@@ -60,27 +60,27 @@ the new value.
Constructs a new Data::Perl::Collection::Number object initialized with the passed
in value, and returns it.
-=item * B<add($value)>
+=item B<add($value)>
Adds the current value of the attribute to C<$value>.
-=item * B<sub($value)>
+=item B<sub($value)>
Subtracts C<$value> from the current value of the attribute.
-=item * B<mul($value)>
+=item B<mul($value)>
Multiplies the current value of the attribute by C<$value>.
-=item * B<div($value)>
+=item B<div($value)>
Divides the current value of the attribute by C<$value>.
-=item * B<mod($value)>
+=item B<mod($value)>
Returns the current value of the attribute modulo C<$value>.
-=item * B<abs>
+=item B<abs>
Sets the current value of the attribute to its absolute value.
diff --git a/lib/Data/Perl/Role/String.pm b/lib/Data/Perl/Role/String.pm
index 0a41602..64e4790 100644
--- a/lib/Data/Perl/Role/String.pm
+++ b/lib/Data/Perl/Role/String.pm
@@ -1,5 +1,5 @@
package Data::Perl::Role::String;
-$Data::Perl::Role::String::VERSION = '0.002008';
+$Data::Perl::Role::String::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl scalar strings.
use strictures 1;
@@ -60,7 +60,7 @@ Data::Perl::Role::String - Wrapping class for Perl scalar strings.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/lib/Data/Perl/String.pm b/lib/Data/Perl/String.pm
index 73e0afc..8cd3713 100644
--- a/lib/Data/Perl/String.pm
+++ b/lib/Data/Perl/String.pm
@@ -1,5 +1,5 @@
package Data::Perl::String;
-$Data::Perl::String::VERSION = '0.002008';
+$Data::Perl::String::VERSION = '0.002009';
# ABSTRACT: Wrapping class for Perl scalar strings.
use strictures 1;
@@ -20,7 +20,7 @@ Data::Perl::String - Wrapping class for Perl scalar strings.
=head1 VERSION
-version 0.002008
+version 0.002009
=head1 SYNOPSIS
diff --git a/t/release-pod-syntax.t b/t/release-pod-syntax.t
new file mode 100644
index 0000000..cdd6a6c
--- /dev/null
+++ b/t/release-pod-syntax.t
@@ -0,0 +1,14 @@
+#!perl
+
+BEGIN {
+ unless ($ENV{RELEASE_TESTING}) {
+ require Test::More;
+ Test::More::plan(skip_all => 'these tests are for release candidate testing');
+ }
+}
+
+# This file was automatically generated by Dist::Zilla::Plugin::PodSyntaxTests.
+use Test::More;
+use Test::Pod 1.41;
+
+all_pod_files_ok();