summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2023-10-25 21:08:25 +0200
committergregor herrmann <gregoa@debian.org>2023-10-25 21:08:25 +0200
commit15e8f29ee015523c5f620ad3368fc93ad3532846 (patch)
tree524ae9fb64f12130e4c8dea4c039344bb5cd7c34
parent317817a9e5983f0c071881967d7f79c02188aeef (diff)
debian/rules: add check for nocheck in $(DEB_BUILD_OPTIONS).
I think lintian is wrong here wrt to debhelper but it doesn't hurt so *shrug*
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 2dee1ad..c1463d4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,9 +13,11 @@ override_dh_auto_configure:
PERL_DBD_ODBC_PREFER_UNIXODBC=1 dh_auto_configure
override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
DBI_DSN=dbi:ODBC:"DRIVER=SQLite3;database=$(TESTDB)" dh_auto_test
# remove testdb after tests
$(RM) -v $(TESTDB)
+endif
override_dh_installexamples:
dh_installexamples