summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSalvatore Bonaccorso <carnil@debian.org>2011-07-25 19:48:07 +0000
committerSalvatore Bonaccorso <carnil@debian.org>2011-07-25 19:48:07 +0000
commiteef7caabd1c539b881c88632ab71011526f4db37 (patch)
treea1f9d5e72b4a1d849e983c91caf338905b0b0db4
parenta48c96fb543fe87655a157eb20adb2af2745004a (diff)
[svn-upgrade] new version libdigest-hmac-perl (1.03+dfsg)
-rw-r--r--Changes10
-rw-r--r--META.yml10
-rw-r--r--Makefile.PL2
-rw-r--r--lib/Digest/HMAC.pm11
-rw-r--r--lib/Digest/HMAC_SHA1.pm8
5 files changed, 30 insertions, 11 deletions
diff --git a/Changes b/Changes
index 57de563..bc48cad 100644
--- a/Changes
+++ b/Changes
@@ -1,3 +1,13 @@
+2011-07-25 Gisle Aas <gisle@ActiveState.com>
+
+ Release 1.03
+
+ Depend on Digest::SHA instead of Digest::SHA1 [RT#69776]
+
+ Document the blocksize argument [RT#14551]
+
+
+
2010-01-10 Gisle Aas <gisle@ActiveState.com>
Release 1.02
diff --git a/META.yml b/META.yml
index 6251f41..61c2dda 100644
--- a/META.yml
+++ b/META.yml
@@ -1,6 +1,6 @@
--- #YAML:1.0
name: Digest-HMAC
-version: 1.02
+version: 1.03
abstract: Keyed-Hashing for Message Authentication
author:
- Gisle Aas <gisle@activestate.com>
@@ -11,14 +11,14 @@ configure_requires:
build_requires:
ExtUtils::MakeMaker: 0
requires:
- Digest::MD5: 2
- Digest::SHA1: 1
- perl: 5.004
+ Digest::MD5: 2
+ Digest::SHA: 1
+ perl: 5.004
no_index:
directory:
- t
- inc
-generated_by: ExtUtils::MakeMaker version 6.55_02
+generated_by: ExtUtils::MakeMaker version 6.57_05
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
version: 1.4
diff --git a/Makefile.PL b/Makefile.PL
index 76cda5f..27fe608 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -6,7 +6,7 @@ WriteMakefile(
'VERSION_FROM' => 'lib/Digest/HMAC.pm',
'ABSTRACT_FROM' => 'lib/Digest/HMAC.pm',
'PREREQ_PM' => { 'Digest::MD5' => 2.00,
- 'Digest::SHA1' => 1.00,
+ 'Digest::SHA' => 1.00,
},
'AUTHOR' => 'Gisle Aas <gisle@activestate.com>',
'LICENSE' => 'perl',
diff --git a/lib/Digest/HMAC.pm b/lib/Digest/HMAC.pm
index 5a548bc..9a164f8 100644
--- a/lib/Digest/HMAC.pm
+++ b/lib/Digest/HMAC.pm
@@ -1,5 +1,5 @@
package Digest::HMAC;
-$VERSION = "1.02";
+$VERSION = "1.03";
use strict;
@@ -98,6 +98,15 @@ HMAC follow the common C<Digest::> interface, but the constructor
takes the secret key and the name of some other simple C<Digest::>
as argument.
+The hmac() and hmac_hex() functions and the Digest::HMAC->new() constructor
+takes an optional $blocksize argument as well. The HMAC algorithm assumes the
+digester to hash by iterating a basic compression function on blocks of data
+and the $blocksize should match the byte-length of such blocks.
+
+The default $blocksize is 64 which is suitable for the MD5 and SHA-1 digest
+functions. For stronger algorithms the blocksize probably needs to be
+increased.
+
=head1 SEE ALSO
L<Digest::HMAC_MD5>, L<Digest::HMAC_SHA1>
diff --git a/lib/Digest/HMAC_SHA1.pm b/lib/Digest/HMAC_SHA1.pm
index fadfb40..c63b00f 100644
--- a/lib/Digest/HMAC_SHA1.pm
+++ b/lib/Digest/HMAC_SHA1.pm
@@ -1,8 +1,8 @@
package Digest::HMAC_SHA1;
-$VERSION="1.01";
+$VERSION="1.03";
use strict;
-use Digest::SHA1 qw(sha1);
+use Digest::SHA qw(sha1);
use Digest::HMAC qw(hmac);
# OO interface
@@ -11,7 +11,7 @@ use vars qw(@ISA);
sub new
{
my $class = shift;
- $class->SUPER::new($_[0], "Digest::SHA1", 64);
+ $class->SUPER::new($_[0], "Digest::SHA", 64); # Digest::SHA defaults to SHA-1
}
# Functional interface
@@ -62,7 +62,7 @@ This module provide HMAC-SHA-1 hashing.
=head1 SEE ALSO
-L<Digest::HMAC>, L<Digest::SHA1>, L<Digest::HMAC_MD5>
+L<Digest::HMAC>, L<Digest::SHA>, L<Digest::HMAC_MD5>
=head1 AUTHOR