summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL126
1 files changed, 74 insertions, 52 deletions
diff --git a/Makefile.PL b/Makefile.PL
index cd34459..4f7dab5 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,74 +1,96 @@
-# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
+BEGIN {
+ use strict; use warnings;
+ unless(eval q{ use 5.014; 1}) {
+ print "Perl 5.014 or better required\n";
+ exit;
+ }
+}
+BEGIN {
+ use strict; use warnings;
+ my %missing = map {
+ eval qq{ require $_ };
+ $@ ? ($_=>1) : ()
+ } qw( Carp File::Spec IO::Handle IPC::Open3 Test::More strict warnings );
+ if(%missing)
+ {
+ print "Your Perl is missing core modules: @{[ sort keys %missing ]}\n";
+ print "Ideally if you are using the system Perl you can install the appropriate\n";
+ print "package which includes the core Perl modules. On at least some versions\n";
+ print "of Fedora, CentOS and RHEL, this is the `perl-core` package.\n";
+ print "\n";
+ print " % dnf install perl-core\n";
+ print " ~ or ~\n";
+ print " % yum install perl-core\n";
+ print "\n";
+ print "If you really want to install dual-life modules from CPAN, then you can\n";
+ print "use cpanm:\n";
+ print "\n";
+ print " % cpanm @{[ sort keys %missing ]}\n";
+ print "\n";
+ print "Note that some core modules are not available from CPAN.\n";
+ exit;
+ }
+}
+# This file was automatically generated by Dist::Zilla::Plugin::Author::Plicease::MakeMaker v2.36.
use strict;
use warnings;
-
-use 5.008;
-
+use 5.014;
use ExtUtils::MakeMaker;
my %WriteMakefileArgs = (
- "ABSTRACT" => "No line insertion and does Package version with our",
- "AUTHOR" => "Caleb Cushing <xenoterracide\@gmail.com>, Grahan Ollis <plicease\@cpan.org>",
+ "ABSTRACT" => "No line insertion and does Package version with our",
+ "AUTHOR" => "Caleb Cushing <xenoterracide\@gmail.com>, Grahan Ollis <plicease\@cpan.org>",
"CONFIGURE_REQUIRES" => {
"ExtUtils::MakeMaker" => 0
},
- "DISTNAME" => "Dist-Zilla-Plugin-OurPkgVersion",
- "LICENSE" => "artistic_2",
- "MIN_PERL_VERSION" => "5.008",
- "NAME" => "Dist::Zilla::Plugin::OurPkgVersion",
+ "DISTNAME" => "Dist-Zilla-Plugin-OurPkgVersion",
+ "LICENSE" => "artistic_2",
+ "MIN_PERL_VERSION" => "5.014",
+ "NAME" => "Dist::Zilla::Plugin::OurPkgVersion",
+ "PM" => {
+ "lib/Dist/Zilla/Plugin/OurPkgVersion.pm" => "\$(INST_LIB)/Dist/Zilla/Plugin/OurPkgVersion.pm"
+ },
"PREREQ_PM" => {
- "Carp" => 0,
- "Dist::Zilla" => "5.038",
+ "Dist::Zilla" => "6.00",
"Dist::Zilla::Role::FileFinderUser" => 0,
- "Dist::Zilla::Role::FileMunger" => 0,
- "Dist::Zilla::Role::PPI" => 0,
- "Moose" => 0,
- "MooseX::Types::Perl" => 0,
- "PPI" => 0,
- "namespace::autoclean" => 0,
- "strict" => 0,
- "warnings" => 0
+ "Dist::Zilla::Role::FileMunger" => 0,
+ "Dist::Zilla::Role::PPI" => 0,
+ "Moose" => 0,
+ "MooseX::Types::Perl" => 0,
+ "PPI" => 0,
+ "namespace::autoclean" => 0
},
"TEST_REQUIRES" => {
- "ExtUtils::MakeMaker" => 0,
- "File::Spec" => 0,
- "IO::Handle" => 0,
- "IPC::Open3" => 0,
- "Path::Tiny" => 0,
- "Test::DZil" => 0,
- "Test::More" => 0,
- "Test::Version" => "0.04"
+ "Dist::Zilla::Role::VersionProvider" => 0,
+ "ExtUtils::MakeMaker" => 0,
+ "Path::Tiny" => 0,
+ "Test::DZil" => 0,
+ "Test::Exception" => 0,
+ "Test::Version" => "0.04"
},
- "VERSION" => "0.14",
- "test" => {
+ "VERSION" => "0.20",
+ "test" => {
"TESTS" => "t/*.t"
}
);
-
my %FallbackPrereqs = (
- "Carp" => 0,
- "Dist::Zilla" => "5.038",
- "Dist::Zilla::Role::FileFinderUser" => 0,
- "Dist::Zilla::Role::FileMunger" => 0,
- "Dist::Zilla::Role::PPI" => 0,
- "ExtUtils::MakeMaker" => 0,
- "File::Spec" => 0,
- "IO::Handle" => 0,
- "IPC::Open3" => 0,
- "Moose" => 0,
- "MooseX::Types::Perl" => 0,
- "PPI" => 0,
- "Path::Tiny" => 0,
- "Test::DZil" => 0,
- "Test::More" => 0,
- "Test::Version" => "0.04",
- "namespace::autoclean" => 0,
- "strict" => 0,
- "warnings" => 0
+ "Dist::Zilla" => "6.00",
+ "Dist::Zilla::Role::FileFinderUser" => 0,
+ "Dist::Zilla::Role::FileMunger" => 0,
+ "Dist::Zilla::Role::PPI" => 0,
+ "Dist::Zilla::Role::VersionProvider" => 0,
+ "ExtUtils::MakeMaker" => 0,
+ "Moose" => 0,
+ "MooseX::Types::Perl" => 0,
+ "PPI" => 0,
+ "Path::Tiny" => 0,
+ "Test::DZil" => 0,
+ "Test::Exception" => 0,
+ "Test::Version" => "0.04",
+ "namespace::autoclean" => 0
);
-
unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
delete $WriteMakefileArgs{TEST_REQUIRES};
delete $WriteMakefileArgs{BUILD_REQUIRES};
@@ -78,4 +100,4 @@ unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
-WriteMakefile(%WriteMakefileArgs);
+WriteMakefile(%WriteMakefileArgs); \ No newline at end of file