summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-03-19 19:08:04 +0100
committergregor herrmann <gregoa@debian.org>2020-03-19 19:08:04 +0100
commita9810843e06c96faabd32e5425abbabd69c5e328 (patch)
tree9f95b620f67b8bbb7891f271d86fa569f8cf8ded
parentb0aa3105c2f80f7e8692ffda49175e819b85623d (diff)
New upstream version 4.33
-rw-r--r--Changes7
-rw-r--r--EV.pm2
-rw-r--r--EV.xs7
-rw-r--r--META.json2
-rw-r--r--META.yml2
-rw-r--r--Makefile.PL2
-rw-r--r--libev/Changes5
-rw-r--r--libev/ev.c4
-rw-r--r--libev/ev.h2
-rw-r--r--libev/ev.pod8
10 files changed, 28 insertions, 13 deletions
diff --git a/Changes b/Changes
index 6d2d9f1..d8b8a1c 100644
--- a/Changes
+++ b/Changes
@@ -3,6 +3,13 @@ Revision history for Perl extension EV
Changes marked with (libev) are changes in libev, and might have more
documentation in the libev Changes file.
+4.33 Wed Mar 18 13:31:12 CET 2020
+ - the enable assertion makefile question failed to enable
+ assertions due to a typo.
+ - try harder to avoid perl's assert () which does not actually
+ behave correctly.
+ - updated libecb to make it compile under more windows environments.
+
4.32 Fri Jan 24 14:21:35 CET 2020
- (libev) fixed a bug introduced in 4.31 when timerfds and signalfds were
used at the same time.
diff --git a/EV.pm b/EV.pm
index aa3d954..bfa64e4 100644
--- a/EV.pm
+++ b/EV.pm
@@ -121,7 +121,7 @@ package EV;
use common::sense;
BEGIN {
- our $VERSION = '4.32';
+ our $VERSION = '4.33';
use XSLoader;
local $^W = 0; # avoid spurious warning
XSLoader::load "EV", $VERSION;
diff --git a/EV.xs b/EV.xs
index 023d81c..72c59fa 100644
--- a/EV.xs
+++ b/EV.xs
@@ -23,9 +23,14 @@ sv_fileno (SV *fh)
#if EV_ENABLE_ASSERTIONS
# undef NDEBUG
-# include <assert.h>
+#else
+# define NDEBUG 1
#endif
+/* make sure we get a real assert, not perl's incompatible version */
+#undef assert
+#include <assert.h>
+
#define EV_STANDALONE 1
#define EV_PROTOTYPES 1
#define EV_USE_NANOSLEEP EV_USE_MONOTONIC
diff --git a/META.json b/META.json
index 56b0b2c..69951ff 100644
--- a/META.json
+++ b/META.json
@@ -38,5 +38,5 @@
}
},
"release_status" : "stable",
- "version" : "4.32"
+ "version" : "4.33"
}
diff --git a/META.yml b/META.yml
index 85e3f83..5a67c94 100644
--- a/META.yml
+++ b/META.yml
@@ -20,4 +20,4 @@ no_index:
- inc
requires:
common::sense: '0'
-version: '4.32'
+version: '4.33'
diff --git a/Makefile.PL b/Makefile.PL
index 7d409db..680dda9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -373,7 +373,7 @@ EOF
my $enable_assertions = 0;
$enable_assertions = 0 + (prompt ("Make sure assertions are enabled? (y/n)?", $enable_assertions ? "y" : "n") =~ /[yY]/);
-$DEFINE .= " -DEV_ENABLE_ASERTIONS=1" if $enable_assertions;
+$DEFINE .= " -DEV_ENABLE_ASSERTIONS=1" if $enable_assertions;
print <<EOF;
diff --git a/libev/Changes b/libev/Changes
index 80e70ae..d200b9e 100644
--- a/libev/Changes
+++ b/libev/Changes
@@ -3,8 +3,11 @@ Revision history for libev, a high-performance and full-featured event loop.
TODO: for next ABI/API change, consider moving EV__IOFDSSET into io->fd instead and provide a getter.
TODO: document EV_TSTAMP_T
+4.33 Wed Mar 18 13:22:29 CET 2020
+ - no changes w.r.t. 4.32.
+
4.32 (EV only)
- - the 4.31 timerfd code wrongly changes the priority of the signal
+ - the 4.31 timerfd code wrongly changed the priority of the signal
fd watcher, which is usually harmless unless signal fds are
also used (found via cpan tester service).
- the documentation wrongly claimed that user may modify fd and events
diff --git a/libev/ev.c b/libev/ev.c
index 9214174..7145309 100644
--- a/libev/ev.c
+++ b/libev/ev.c
@@ -1,7 +1,7 @@
/*
* libev event processing core, watcher management
*
- * Copyright (c) 2007-2019 Marc Alexander Lehmann <libev@schmorp.de>
+ * Copyright (c) 2007-2020 Marc Alexander Lehmann <libev@schmorp.de>
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without modifica-
@@ -651,7 +651,7 @@ struct signalfd_siginfo
#include <string.h> /* for memcpy */
-#ifdef _WIN32
+#if defined (_WIN32) && !defined (__MINGW32__)
typedef signed char int8_t;
typedef unsigned char uint8_t;
typedef signed char int_fast8_t;
diff --git a/libev/ev.h b/libev/ev.h
index 90ad79f..4669c39 100644
--- a/libev/ev.h
+++ b/libev/ev.h
@@ -215,7 +215,7 @@ struct ev_loop;
/*****************************************************************************/
#define EV_VERSION_MAJOR 4
-#define EV_VERSION_MINOR 32
+#define EV_VERSION_MINOR 33
/* eventmask, revents, events... */
enum {
diff --git a/libev/ev.pod b/libev/ev.pod
index 08b46b0..e4eeb50 100644
--- a/libev/ev.pod
+++ b/libev/ev.pod
@@ -1843,10 +1843,10 @@ starting an io watcher watching for no events you should do so.
=item ev_io_modify (ev_io *, int events)
-Similar to C<ev_io_set>, but only changes the event mask. Using this might
-be faster with some backends, as libev can assume that the C<fd> still
-refers to the same underlying file description, something it cannot do
-when using C<ev_io_set>.
+Similar to C<ev_io_set>, but only changes the requested events. Using this
+might be faster with some backends, as libev can assume that the C<fd>
+still refers to the same underlying file description, something it cannot
+do when using C<ev_io_set>.
=item int fd [no-modify]