summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL91
1 files changed, 68 insertions, 23 deletions
diff --git a/Makefile.PL b/Makefile.PL
index aa7951c..72311aa 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,24 +1,69 @@
-# Note: this file was auto-generated by Module::Build::Compat version 0.03
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v6.012.
+use strict;
+use warnings;
+
+use 5.010000;
+
use ExtUtils::MakeMaker;
-WriteMakefile
-(
- 'PL_FILES' => {},
- 'INSTALLDIRS' => 'site',
- 'NAME' => 'Graphics::ColorNames',
- 'EXE_FILES' => [],
- 'VERSION_FROM' => 'lib/Graphics/ColorNames.pm',
- 'PREREQ_PM' => {
- 'base' => 0,
- 'Test::Exception' => 0,
- 'IO::File' => 0,
- 'File::Spec' => 0,
- 'FileHandle' => 0,
- 'Exporter' => 0,
- 'Carp' => 0,
- 'Test::More' => 0,
- 'Module::Loaded' => 0,
- 'Module::Load' => '0.10',
- 'DirHandle' => 0
- }
- )
-;
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "defines RGB values for common color names",
+ "AUTHOR" => "Robert Rothenberg <rrwo\@cpan.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => 0
+ },
+ "DISTNAME" => "Graphics-ColorNames",
+ "LICENSE" => "artistic_2",
+ "MIN_PERL_VERSION" => "5.010000",
+ "NAME" => "Graphics::ColorNames",
+ "PREREQ_PM" => {
+ "Exporter" => "5.57",
+ "Module::Load" => "0.10",
+ "Module::Loaded" => 0,
+ "version" => 0
+ },
+ "TEST_REQUIRES" => {
+ "File::Spec" => 0,
+ "FileHandle" => 0,
+ "IO::File" => 0,
+ "Module::Metadata" => 0,
+ "Test::Exception" => 0,
+ "Test::More" => 0,
+ "Test::Most" => 0,
+ "constant" => 0,
+ "lib" => 0
+ },
+ "VERSION" => "v3.5.0",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Exporter" => "5.57",
+ "File::Spec" => 0,
+ "FileHandle" => 0,
+ "IO::File" => 0,
+ "Module::Load" => "0.10",
+ "Module::Loaded" => 0,
+ "Module::Metadata" => 0,
+ "Test::Exception" => 0,
+ "Test::More" => 0,
+ "Test::Most" => 0,
+ "constant" => 0,
+ "lib" => 0,
+ "version" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);