summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiko Tyni <ntyni@debian.org>2018-05-06 20:00:50 +0300
committerNiko Tyni <ntyni@debian.org>2018-05-06 20:21:26 +0300
commit2fcd9ec33ea8b0271777d0b346d5bc00dfdb95d8 (patch)
treed2164852276227aa6c539f5280cf7093021dd5ef
parentc1bb47a65850236582b6330706ef61391d291e3d (diff)
Skip network tests on build time too
-rwxr-xr-xdebian/rules7
1 files changed, 4 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 686addd..69fe3bd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,8 @@
%:
dh $@
+SKIP_TESTS = $(shell cat debian/tests/pkg-perl/smoke-skip)
+TEST_FILES = $(filter-out $(SKIP_TESTS), $(shell echo t/*.t))
+
override_dh_auto_test:
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- -make -j1 test TEST_VERBOSE=1
-endif
+ dh_auto_test -- TEST_FILES="$(TEST_FILES)"