summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2021-12-25 16:34:01 +0100
committergregor herrmann <gregoa@debian.org>2021-12-25 16:34:01 +0100
commit950e84d2faf8abaaf4d2b005057a198ad756abf6 (patch)
treebf34e632ee5060c224cfa994832b57fc77eadc2f
parent7449e6c811c058d5d188e0601c485ca743715aeb (diff)
parent6abb6739535ede4a2e9843e3035fad57d6463608 (diff)
Update upstream source from tag 'upstream/281'
Update to upstream version '281' with Debian dir 8f19fa01d086a76c8e32da5b637a614403498654
-rw-r--r--Changes3
-rw-r--r--META.json2
-rw-r--r--Makefile.PL2
-rw-r--r--lib/REST/Client.pm5
4 files changed, 7 insertions, 5 deletions
diff --git a/Changes b/Changes
index a136025..ddede02 100644
--- a/Changes
+++ b/Changes
@@ -1,6 +1,9 @@
History for the REST-Client Perl distribution
+281 2021-12-17
+ * Allow arbitrary request verbs (RT #124620)
+
280 2021-12-14
* Convert build system to MakeMaker and Dist::Zilla
Fixes the installation on recent Perl without '.' in @INC
diff --git a/META.json b/META.json
index 74d4400..95120be 100644
--- a/META.json
+++ b/META.json
@@ -59,7 +59,7 @@
"web" : "https://github.com/milescrawford/cpan-rest-client"
}
},
- "version" : "280",
+ "version" : "281",
"x_generated_by_perl" : "v5.34.0",
"x_serialization_backend" : "Cpanel::JSON::XS version 4.27",
"x_spdx_expression" : "Artistic-1.0-Perl OR GPL-1.0-or-later"
diff --git a/Makefile.PL b/Makefile.PL
index c718a29..9566e9b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -31,7 +31,7 @@ my %WriteMakefileArgs = (
"HTTP::Server::Simple" => 0,
"Test::More" => 0
},
- "VERSION" => 280,
+ "VERSION" => 281,
"test" => {
"TESTS" => "t/*.t"
}
diff --git a/lib/REST/Client.pm b/lib/REST/Client.pm
index 8db7b85..9181d6d 100644
--- a/lib/REST/Client.pm
+++ b/lib/REST/Client.pm
@@ -1,7 +1,7 @@
package REST::Client;
#ABSTRACT: A simple client for interacting with RESTful http/https resources
-our $VERSION = '280';
+our $VERSION = '281';
@@ -125,7 +125,6 @@ sub request {
#error check
- croak "REST::Client exception: First argument to request must be one of GET, PATCH, PUT, POST, DELETE, OPTIONS, HEAD" unless $method =~ /^(get|patch|put|post|delete|options|head)$/i;
croak "REST::Client exception: Must provide a url to $method" unless $url;
croak "REST::Client exception: headers must be presented as a hashref" if $headers && ref $headers ne 'HASH';
@@ -317,7 +316,7 @@ REST::Client - A simple client for interacting with RESTful http/https resources
=head1 VERSION
-version 280
+version 281
=head1 SYNOPSIS