summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2021-12-25 16:15:56 +0100
committergregor herrmann <gregoa@debian.org>2021-12-25 16:15:56 +0100
commit036ca03b384cfeb57b0336dd534772f1d5c7ce07 (patch)
tree5c76378829cb76f39bfdd93bb3d5b8ab864ee79f
parent0719ebcfbca82b1bd84de8d310629722b13905c8 (diff)
parent7b769d06e1408515eff46afa6c758bdb1b24c13e (diff)
Update upstream source from tag 'upstream/0.33'
Update to upstream version '0.33' with Debian dir 6f21a45f3862179bd2fdfeb6b58cf92019a35b84
-rw-r--r--Changes10
-rw-r--r--META.json12
-rw-r--r--META.yml7
-rw-r--r--Makefile.PL23
-rw-r--r--README7
-rw-r--r--lib/Scope/Upper.pm6
-rw-r--r--t/07-context_info.t6
-rw-r--r--t/lib/Test/Leaner.pm2
8 files changed, 55 insertions, 18 deletions
diff --git a/Changes b/Changes
index e891e8e..cd12fdd 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,15 @@
Revision history for Scope-Upper
+0.33 2021-12-20 20:30 UTC
+ + Fix : [RT #114816] resources/remote/url points to web interface
+ META files now follow version 2.0 of the CPAN META spec.
+ Thanks Kent Fredric for reporting.
+ + Fix : [RT #139823] : Perl 5 blead breads t/07-context_info.t
+ t/07-context_info.t has been hardened against warning bits
+ changes.
+ Thanks Jim Keenan and Tony Cook for reporting and contributing
+ a fix.
+
0.32 2019-07-08 12:50 UTC
+ Fix : [RT #129539] : fails with v5.27.3 and later with DEBUGGING
The module has been amended to accomodate with a change of
diff --git a/META.json b/META.json
index 502434b..f3ea0a8 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
"Vincent Pit <vpit@cpan.org>"
],
"dynamic_config" : 1,
- "generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010",
+ "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
"license" : [
"perl_5"
],
@@ -33,7 +33,6 @@
},
"configure" : {
"requires" : {
- "Config" : "0",
"ExtUtils::MakeMaker" : "0"
}
},
@@ -49,6 +48,7 @@
"release_status" : "stable",
"resources" : {
"bugtracker" : {
+ "mailto" : "bug-scope-upper@rt.cpan.org",
"web" : "http://rt.cpan.org/Dist/Display.html?Name=Scope-Upper"
},
"homepage" : "http://search.cpan.org/dist/Scope-Upper/",
@@ -56,9 +56,11 @@
"http://dev.perl.org/licenses/"
],
"repository" : {
- "url" : "http://git.vpit.fr/?p=perl%2Fmodules%2FScope-Upper.git"
+ "type" : "git",
+ "url" : "http://git.vpit.fr/perl/modules/Scope-Upper.git/",
+ "web" : "http://git.vpit.fr/?p=perl%2Fmodules%2FScope-Upper.git"
}
},
- "version" : "0.32",
- "x_serialization_backend" : "JSON::PP version 4.02"
+ "version" : "0.33",
+ "x_serialization_backend" : "JSON::PP version 4.06"
}
diff --git a/META.yml b/META.yml
index c8d2c85..ac67f34 100644
--- a/META.yml
+++ b/META.yml
@@ -11,10 +11,9 @@ build_requires:
XSLoader: '0'
base: '0'
configure_requires:
- Config: '0'
ExtUtils::MakeMaker: '0'
dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010'
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -33,6 +32,6 @@ resources:
bugtracker: http://rt.cpan.org/Dist/Display.html?Name=Scope-Upper
homepage: http://search.cpan.org/dist/Scope-Upper/
license: http://dev.perl.org/licenses/
- repository: http://git.vpit.fr/?p=perl%2Fmodules%2FScope-Upper.git
-version: '0.32'
+ repository: http://git.vpit.fr/perl/modules/Scope-Upper.git/
+version: '0.33'
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Makefile.PL b/Makefile.PL
index 396ccec..507fa0c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -86,6 +86,14 @@ my $dist = 'Scope-Upper';
(my $file = $dist) =~ s{-}{/}g;
$file = "lib/$file.pm";
+my $bug_web = "http://rt.cpan.org/Dist/Display.html?Name=$dist",
+my $bug_mailto = 'bug-' . lc($dist) . '@rt.cpan.org';
+
+my $repo_host = 'git.vpit.fr';
+my @repo_path = ('perl', 'modules', "$dist.git");
+my $repo_url = join '/', 'http:', '', $repo_host, @repo_path, '';
+my $repo_web = "http://$repo_host/?p=" . join('%2F', @repo_path);
+
my %PREREQ_PM = (
'Exporter' => 0,
'XSLoader' => 0,
@@ -101,6 +109,10 @@ my %BUILD_REQUIRES = (
);
my %META = (
+ 'meta-spec' => {
+ version => '2',
+ url => 'http://search.cpan.org/perldoc?CPAN::Meta::Spec',
+ },
configure_requires => {
'Config' => 0,
'ExtUtils::MakeMaker' => 0,
@@ -110,10 +122,17 @@ my %META = (
},
dynamic_config => 1,
resources => {
- bugtracker => "http://rt.cpan.org/Dist/Display.html?Name=$dist",
+ bugtracker => {
+ web => $bug_web,
+ mailto => $bug_mailto,
+ },
homepage => "http://search.cpan.org/dist/$dist/",
license => 'http://dev.perl.org/licenses/',
- repository => "http://git.vpit.fr/?p=perl%2Fmodules%2F$dist.git",
+ repository => {
+ type => 'git',
+ url => $repo_url,
+ web => $repo_web,
+ },
},
);
diff --git a/README b/README
index 15bb1ec..bb108eb 100644
--- a/README
+++ b/README
@@ -2,7 +2,7 @@ NAME
Scope::Upper - Act on upper scopes.
VERSION
- Version 0.32
+ Version 0.33
SYNOPSIS
"reap", "localize", "localize_elem", "localize_delete" and "WORDS" :
@@ -823,8 +823,9 @@ ACKNOWLEDGEMENTS
Thanks to Shawn M. Moore for motivation.
COPYRIGHT & LICENSE
- Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019
- Vincent Pit, all rights reserved.
+ Copyright
+ 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019,2021 Vincent
+ Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/lib/Scope/Upper.pm b/lib/Scope/Upper.pm
index 690aa5b..d35eefd 100644
--- a/lib/Scope/Upper.pm
+++ b/lib/Scope/Upper.pm
@@ -11,13 +11,13 @@ Scope::Upper - Act on upper scopes.
=head1 VERSION
-Version 0.32
+Version 0.33
=cut
our $VERSION;
BEGIN {
- $VERSION = '0.32';
+ $VERSION = '0.33';
}
=head1 SYNOPSIS
@@ -865,7 +865,7 @@ Thanks to Shawn M. Moore for motivation.
=head1 COPYRIGHT & LICENSE
-Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019 Vincent Pit, all rights reserved.
+Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019,2021 Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.
diff --git a/t/07-context_info.t b/t/07-context_info.t
index 5dbfa45..657285f 100644
--- a/t/07-context_info.t
+++ b/t/07-context_info.t
@@ -51,6 +51,9 @@ sub expected {
$warnings = sub { use warnings; (caller 0)[9] }->() if "$]" < 5.007
and not $^W;
}
+ if (defined $warnings and $warnings =~ m/^\x55*$/) {
+ $warnings = $warnings::Bits{all};
+ }
my @exp = (
$pkg,
@@ -156,6 +159,9 @@ sub call {
my @got = context_info(CALLER $depth);
my @exp = caller $depth;
defined and not $_ and $_ = '' for $exp[5];
+ if (defined $exp[9] and $exp[9] =~ m/^\x55*$/) {
+ $exp[9] = $warnings::Bits{all};
+ }
is_deeply \@got, \@exp, "context_info vs caller $depth";
}
}
diff --git a/t/lib/Test/Leaner.pm b/t/lib/Test/Leaner.pm
index 04984d7..c533b4f 100644
--- a/t/lib/Test/Leaner.pm
+++ b/t/lib/Test/Leaner.pm
@@ -931,7 +931,7 @@ You can find documentation for this module with the perldoc command.
=head1 COPYRIGHT & LICENSE
-Copyright 2010,2011,2013,2019 Vincent Pit, all rights reserved.
+Copyright 2010,2011,2013,2021 Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.