summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2019-07-21 20:52:35 +0000
committerintrigeri <intrigeri@boum.org>2019-07-21 20:52:35 +0000
commite8c595ab7e79915e5b5a5c34a02e660db4f715aa (patch)
tree445b860e561ce9a02164a3394040ef3a4c30efa6
parente1a7cd251b6579346b57de6072b3092904240d29 (diff)
parentb9276d0a822f0597b3a4514eda3095c41596e219 (diff)
New upstream version 0.32
-rw-r--r--Changes6
-rw-r--r--META.json8
-rw-r--r--META.yml6
-rw-r--r--Makefile.PL4
-rw-r--r--README8
-rw-r--r--Upper.xs11
-rw-r--r--lib/Scope/Upper.pm8
-rw-r--r--t/lib/Test/Leaner.pm4
-rw-r--r--t/lib/VPIT/TestHelpers.pm4
9 files changed, 35 insertions, 24 deletions
diff --git a/Changes b/Changes
index 70db4c5..e891e8e 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,11 @@
Revision history for Scope-Upper
+0.32 2019-07-08 12:50 UTC
+ + Fix : [RT #129539] : fails with v5.27.3 and later with DEBUGGING
+ The module has been amended to accomodate with a change of
+ behaviour of a core macro.
+ + Upd : Contact info.
+
0.31 2018-08-26 19:50 UTC
+ Fix : [RT #125931] : localized SCALAR doesn't get imported
localize '$Foo::x' => $var now properly imports $x into Foo.
diff --git a/META.json b/META.json
index 3c89d18..502434b 100644
--- a/META.json
+++ b/META.json
@@ -1,7 +1,7 @@
{
"abstract" : "Act on upper scopes.",
"author" : [
- "Vincent Pit <perl@profvince.com>"
+ "Vincent Pit <vpit@cpan.org>"
],
"dynamic_config" : 1,
"generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010",
@@ -56,9 +56,9 @@
"http://dev.perl.org/licenses/"
],
"repository" : {
- "url" : "http://git.profvince.com/?p=perl%2Fmodules%2FScope-Upper.git"
+ "url" : "http://git.vpit.fr/?p=perl%2Fmodules%2FScope-Upper.git"
}
},
- "version" : "0.31",
- "x_serialization_backend" : "JSON::PP version 2.97001"
+ "version" : "0.32",
+ "x_serialization_backend" : "JSON::PP version 4.02"
}
diff --git a/META.yml b/META.yml
index 9fea138..c8d2c85 100644
--- a/META.yml
+++ b/META.yml
@@ -1,7 +1,7 @@
---
abstract: 'Act on upper scopes.'
author:
- - 'Vincent Pit <perl@profvince.com>'
+ - 'Vincent Pit <vpit@cpan.org>'
build_requires:
Config: '0'
Exporter: '0'
@@ -33,6 +33,6 @@ resources:
bugtracker: http://rt.cpan.org/Dist/Display.html?Name=Scope-Upper
homepage: http://search.cpan.org/dist/Scope-Upper/
license: http://dev.perl.org/licenses/
- repository: http://git.profvince.com/?p=perl%2Fmodules%2FScope-Upper.git
-version: '0.31'
+ repository: http://git.vpit.fr/?p=perl%2Fmodules%2FScope-Upper.git
+version: '0.32'
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Makefile.PL b/Makefile.PL
index 787889a..396ccec 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -113,13 +113,13 @@ my %META = (
bugtracker => "http://rt.cpan.org/Dist/Display.html?Name=$dist",
homepage => "http://search.cpan.org/dist/$dist/",
license => 'http://dev.perl.org/licenses/',
- repository => "http://git.profvince.com/?p=perl%2Fmodules%2F$dist.git",
+ repository => "http://git.vpit.fr/?p=perl%2Fmodules%2F$dist.git",
},
);
WriteMakefile(
NAME => $name,
- AUTHOR => 'Vincent Pit <perl@profvince.com>',
+ AUTHOR => 'Vincent Pit <vpit@cpan.org>',
LICENSE => 'perl',
VERSION_FROM => $file,
ABSTRACT_FROM => $file,
diff --git a/README b/README
index 94fbc2a..15bb1ec 100644
--- a/README
+++ b/README
@@ -2,7 +2,7 @@ NAME
Scope::Upper - Act on upper scopes.
VERSION
- Version 0.31
+ Version 0.32
SYNOPSIS
"reap", "localize", "localize_elem", "localize_delete" and "WORDS" :
@@ -797,7 +797,7 @@ SEE ALSO
Scope::Escape.
AUTHOR
- Vincent Pit, "<perl at profvince.com>", <http://www.profvince.com>.
+ Vincent Pit "<vpit at cpan.org>".
You can contact me by mail or on "irc.perl.org" (vincent).
@@ -823,8 +823,8 @@ ACKNOWLEDGEMENTS
Thanks to Shawn M. Moore for motivation.
COPYRIGHT & LICENSE
- Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018 Vincent
- Pit, all rights reserved.
+ Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019
+ Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it
under the same terms as Perl itself.
diff --git a/Upper.xs b/Upper.xs
index 5ab2040..0c762de 100644
--- a/Upper.xs
+++ b/Upper.xs
@@ -2022,12 +2022,17 @@ static int su_uplevel_runops_hook_entersub(pTHX) {
*/
assert(sud);
if (sud->argarray) {
+ I32 fill;
AV *av = newAV();
AvREAL_off(av);
AvREIFY_on(av);
- av_extend(av, AvMAX(sud->argarray));
- AvFILLp(av) = AvFILLp(sud->argarray);
- Copy(AvARRAY(sud->argarray), AvARRAY(av), AvFILLp(av) + 1, SV *);
+
+ fill = AvFILLp(sud->argarray);
+ if (fill >= 0) {
+ av_extend(av, fill);
+ Copy(AvARRAY(sud->argarray), AvARRAY(av), fill + 1, SV *);
+ AvFILLp(av) = fill;
+ }
/* should be referenced by PL_curpad[0] and *_ */
assert(SvREFCNT(PL_curpad[0]) > 1);
diff --git a/lib/Scope/Upper.pm b/lib/Scope/Upper.pm
index ce67708..690aa5b 100644
--- a/lib/Scope/Upper.pm
+++ b/lib/Scope/Upper.pm
@@ -11,13 +11,13 @@ Scope::Upper - Act on upper scopes.
=head1 VERSION
-Version 0.31
+Version 0.32
=cut
our $VERSION;
BEGIN {
- $VERSION = '0.31';
+ $VERSION = '0.32';
}
=head1 SYNOPSIS
@@ -839,7 +839,7 @@ L<Scope::Escape>.
=head1 AUTHOR
-Vincent Pit, C<< <perl at profvince.com> >>, L<http://www.profvince.com>.
+Vincent Pit C<< <vpit at cpan.org> >>.
You can contact me by mail or on C<irc.perl.org> (vincent).
@@ -865,7 +865,7 @@ Thanks to Shawn M. Moore for motivation.
=head1 COPYRIGHT & LICENSE
-Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018 Vincent Pit, all rights reserved.
+Copyright 2008,2009,2010,2011,2012,2013,2014,2015,2016,2017,2018,2019 Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.
diff --git a/t/lib/Test/Leaner.pm b/t/lib/Test/Leaner.pm
index 9944e25..04984d7 100644
--- a/t/lib/Test/Leaner.pm
+++ b/t/lib/Test/Leaner.pm
@@ -914,7 +914,7 @@ L<Exporter>, L<Test::More>.
=head1 AUTHOR
-Vincent Pit, C<< <perl at profvince.com> >>, L<http://www.profvince.com>.
+Vincent Pit C<< <vpit at cpan.org> >>.
You can contact me by mail or on C<irc.perl.org> (vincent).
@@ -931,7 +931,7 @@ You can find documentation for this module with the perldoc command.
=head1 COPYRIGHT & LICENSE
-Copyright 2010,2011,2013 Vincent Pit, all rights reserved.
+Copyright 2010,2011,2013,2019 Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.
diff --git a/t/lib/VPIT/TestHelpers.pm b/t/lib/VPIT/TestHelpers.pm
index f47bee1..aeabc16 100644
--- a/t/lib/VPIT/TestHelpers.pm
+++ b/t/lib/VPIT/TestHelpers.pm
@@ -837,11 +837,11 @@ sub DESTROY { $_[0]->{code}->() }
=head1 AUTHOR
-Vincent Pit, C<< <perl at profvince.com> >>, L<http://www.profvince.com>.
+Vincent Pit C<< <vpit at cpan.org> >>.
=head1 COPYRIGHT & LICENSE
-Copyright 2012,2013,2014,2015 Vincent Pit, all rights reserved.
+Copyright 2012,2013,2014,2015,2019 Vincent Pit, all rights reserved.
This program is free software; you can redistribute it and/or modify it under the same terms as Perl itself.