summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2022-11-23 21:18:35 +0100
committergregor herrmann <gregoa@debian.org>2022-11-23 21:18:35 +0100
commit4899b8c9e0fbe822c8dfeb8febdd28cfc3eed456 (patch)
tree00aa52840c357c20eb05458aff9629efbf2b2552
parent479b91a95d9aaf73a1e12e7d00f630a62c0be05c (diff)
FTCBFS: hard codes the build architecture C++ compiler
Origin: vendor Bug: https://bugs.debian.org/1023487 Forwarded: no Reviewed-by: gregor herrmann <gregoa@debian.org> Last-Update: 2022-11-23 libsgml-parser-opensp-perl fails to cross build from source, because the Makefile.PL hard codes the build architecture C++ compiler. I'm attaching a patch for your convenience to make it use the host one and thus make libsgml-parser-opensp-perl cross buildable. Gbp-Pq: Name cross.patch
-rw-r--r--Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index f3a2eeb..46a6041 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -13,8 +13,8 @@ if ($^O eq "MSWin32")
else
{
# assume some compatible Linux
- $options{LD} = "g++";
- $options{CC} = "g++";
+ $options{CC} = $ENV{CXX} || "g++";
+ $options{LD} = $options{CC};
$options{LIBS} = "-lstdc++ -losp";
}