summaryrefslogtreecommitdiff
path: root/debian/patches/cross.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/cross.patch')
-rw-r--r--debian/patches/cross.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/cross.patch b/debian/patches/cross.patch
new file mode 100644
index 0000000..7aa4882
--- /dev/null
+++ b/debian/patches/cross.patch
@@ -0,0 +1,25 @@
+Description: FTCBFS: hard codes the build architecture C++ compiler
+ libsgml-parser-opensp-perl fails to cross build from source, because the
+ Makefile.PL hard codes the build architecture C++ compiler. I'm attaching a
+ patch for your convenience to make it use the host one and thus make
+ libsgml-parser-opensp-perl cross buildable.
+Origin: vendor
+Bug: https://bugs.debian.org/1023487
+Forwarded: no
+Author: Helmut Grohne <helmut@subdivi.de>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2022-11-23
+
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,8 +13,8 @@
+ else
+ {
+ # assume some compatible Linux
+- $options{LD} = "g++";
+- $options{CC} = "g++";
++ $options{CC} = $ENV{CXX} || "g++";
++ $options{LD} = $options{CC};
+ $options{LIBS} = "-lstdc++ -losp";
+ }
+