summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNilesh Patra <nilesh@debian.org>2023-02-07 09:05:03 +0100
committerAndreas Tille <tille@debian.org>2023-02-07 09:05:03 +0100
commit82579e27c763f5c9f6331f3c735fb986edace0b1 (patch)
treecd160e2454f60b9d4e24f73f590d518b3fee8520
parent603ac29a784834d6da52f5754b6beadd8ac2f338 (diff)
Add a SOVERSION
Last-Update: 2021-05-22 Gbp-Pq: Name soversion.patch
-rw-r--r--vbz_plugin/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/vbz_plugin/CMakeLists.txt b/vbz_plugin/CMakeLists.txt
index f0b1048..565c179 100644
--- a/vbz_plugin/CMakeLists.txt
+++ b/vbz_plugin/CMakeLists.txt
@@ -4,6 +4,7 @@ add_library(vbz_hdf_plugin
vbz_plugin.cpp
vbz_plugin.h
)
+set_target_properties(vbz_hdf_plugin PROPERTIES SOVERSION 0)
add_sanitizers(vbz_hdf_plugin)
generate_export_header(vbz_hdf_plugin EXPORT_FILE_NAME vbz_plugin/vbz_hdf_plugin_export.h)