summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2023-12-05 15:53:57 -0800
committerVagrant Cascadian <vagrant@reproducible-builds.org>2023-12-05 15:53:57 -0800
commit0103a6bf8e85503d7859473c67378341084d142e (patch)
tree0db8e76d30952873ac206cd70aa4d0ac8aaf16b6
parent0d817194dde2519f6559b1b7a50516c46aac5b5b (diff)
[dgit (10.7+deb12u2) quilt-fixup]
-rw-r--r--debian/patches/check-for-devinput-using-ac_check_file.patch44
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/tools-do-not-embed-build-date-and-kernel.patch59
3 files changed, 105 insertions, 0 deletions
diff --git a/debian/patches/check-for-devinput-using-ac_check_file.patch b/debian/patches/check-for-devinput-using-ac_check_file.patch
new file mode 100644
index 0000000..9e6ff7c
--- /dev/null
+++ b/debian/patches/check-for-devinput-using-ac_check_file.patch
@@ -0,0 +1,44 @@
+From: Helmut Grohne <helmut@subdivi.de>
+Date: Mon, 31 May 2021 13:09:56 +0200
+X-Dgit-Generated: 0.10.1-7.3 54cb42673c340f60f85764753d13da093aad4baf
+Subject: Check for /dev/input using AC_CHECK_FILE.
+
+(Closes: #989304)
+
+---
+
+diff --git a/configure.ac b/configure.ac
+index 1d910b0..66f96aa 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -289,29 +289,12 @@ else
+ fi
+
+ AC_MSG_CHECKING(for devinput)
+-AC_RUN_IFELSE([AC_LANG_PROGRAM([[
+- #include <unistd.h>
+-]],[[
+- return access("/dev/input", R_OK) == 0 ? 0 : 1;
+-]])],[
++AC_CHECK_FILE([/dev/input],[
+ have_devinput="yes"
+ AC_MSG_RESULT(yes)
+ ],[
+ AC_MSG_RESULT(no)
+ have_devinput="no"
+-],[
+- AS_IF([test x$DEVINPUT_HEADER = x -a x$enable_devinput = xyes], [
+- AC_MSG_ERROR([
+- cannot cross-compile with devinput without DEVINPUT_HEADER
+- defined, giving up
+- ])
+- ])
+- if test -n "$DEVINPUT_HEADER" ; then
+- have_devinput="yes"
+- else
+- have_devinput="no"
+- fi
+- AC_MSG_RESULT(yes)
+ ])
+
+
diff --git a/debian/patches/series b/debian/patches/series
index f3ce07d..c299806 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -9,3 +9,5 @@
0009-Replace-the-obsolete-get_event_loop-with-get_running.patch
0010-Patch-configure.ac-to-support-passing-MODINFO.patch
0011-yaml.load.diff
+tools-do-not-embed-build-date-and-kernel.patch
+check-for-devinput-using-ac_check_file.patch
diff --git a/debian/patches/tools-do-not-embed-build-date-and-kernel.patch b/debian/patches/tools-do-not-embed-build-date-and-kernel.patch
new file mode 100644
index 0000000..f1fe355
--- /dev/null
+++ b/debian/patches/tools-do-not-embed-build-date-and-kernel.patch
@@ -0,0 +1,59 @@
+From: Vagrant Cascadian <vagrant@reproducible-builds.org>
+Date: Sat, 2 Jan 2021 00:01:20 +0000
+X-Dgit-Generated: 0.10.1-7.3 1f430917c5ab786478d575d9714dd4e19defd8e1
+Subject: tools: Do not embed build date and kernel version in various files.
+
+(Closes: #979019)
+
+https://reproducible-builds.org/docs/timestamps/
+https://tests.reproducible-builds.org/debian/issues/unstable/captures_kernel_version_issue.html
+
+Partially fixed upstream:
+https://sourceforge.net/p/lirc/git/merge-requests/36/
+
+---
+
+diff --git a/tools/irdb-get b/tools/irdb-get
+index e4e0a26..7688475 100755
+--- a/tools/irdb-get
++++ b/tools/irdb-get
+@@ -193,7 +193,7 @@ def do_yaml_config():
+ lircmd_by_driver[driver].append("%s/%s" % (tokens[0], tokens[2]))
+
+ print("#")
+- print("# Created by 'irdb-get yaml-config' at " + time.ctime())
++ print("# Created by 'irdb-get yaml-config' ")
+ print("#")
+ print("\nlircd_by_driver:")
+ print_yaml_dict(lircd_by_driver)
+diff --git a/tools/lirc-lsplugins.cpp b/tools/lirc-lsplugins.cpp
+index ba67a3c..d38087f 100644
+--- a/tools/lirc-lsplugins.cpp
++++ b/tools/lirc-lsplugins.cpp
+@@ -415,10 +415,9 @@ static void print_header(void)
+ static void print_yaml_header(void)
+ {
+ static const char* const YAML_HEADER =
+- "#\n# Generated by lirc-lsplugins --yaml (%s) at %s#\n ";
+- const time_t now = time(NULL);
++ "#\n# Generated by lirc-lsplugins --yaml (%s)\n ";
+
+- printf(YAML_HEADER, VERSION, ctime(&now));
++ printf(YAML_HEADER, VERSION);
+ printf("\ndrivers:\n");
+ }
+
+diff --git a/tools/lirc-make-devinput b/tools/lirc-make-devinput
+index f7e6f97..c37b5e1 100755
+--- a/tools/lirc-make-devinput
++++ b/tools/lirc-make-devinput
+@@ -61,8 +61,7 @@ if test -n "$lirc_map"; then
+ fi
+
+
+-echo "# Generated by $(basename $0) on $(uname -r)"
+-echo "# Date: $(date)"
++echo "# Generated by $(basename $0)"
+ cat <<EOF
+
+ begin remote