summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrew.shadura@collabora.co.uk>2017-06-15 18:18:34 +0200
committerAndrew Shadura <andrew.shadura@collabora.co.uk>2017-06-15 18:23:23 +0200
commit15e3f3b72a9baae5f238daced43c600ca9154212 (patch)
tree1f3383da49a49acebbbe49592244311613f6263e
parentc67d1c1bb55be23cd60a0e4192e6e17bb526a9e4 (diff)
Sync the tree with the tarball.debian/0.1.2-1archive/debian/0.1.2-1
-rw-r--r--.gitignore8
-rw-r--r--.travis.yml13
-rw-r--r--PKG-INFO44
-rw-r--r--debian/patches/0002-document-debug-level.patch56
-rw-r--r--debian/patches/series1
-rw-r--r--docs/README.rst31
-rw-r--r--matrix_synapse_ldap3.egg-info/PKG-INFO44
-rw-r--r--matrix_synapse_ldap3.egg-info/SOURCES.txt15
-rw-r--r--matrix_synapse_ldap3.egg-info/dependency_links.txt1
-rw-r--r--matrix_synapse_ldap3.egg-info/requires.txt3
-rw-r--r--matrix_synapse_ldap3.egg-info/top_level.txt1
-rw-r--r--setup.cfg6
-rwxr-xr-xsetup.py3
13 files changed, 173 insertions, 53 deletions
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 4231ebb..0000000
--- a/.gitignore
+++ /dev/null
@@ -1,8 +0,0 @@
-.coverage
-.tox/
-__pycache__/
-*.egg-info/
-*.pyc
-build/
-dist/
-_trial_temp/
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index f384224..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,13 +0,0 @@
-language: python
-env:
-- TOXENV=packaging
-- TOXENV=pep8
-- TOXENV=py27-ldap0
-- TOXENV=py27-ldap1
-- TOXENV=py27-ldap2
-
-install:
-- pip install tox
-
-script:
-- tox
diff --git a/PKG-INFO b/PKG-INFO
new file mode 100644
index 0000000..58cfe1a
--- /dev/null
+++ b/PKG-INFO
@@ -0,0 +1,44 @@
+Metadata-Version: 1.1
+Name: matrix-synapse-ldap3
+Version: 0.1.2
+Summary: An LDAP3 auth provider for Synapse
+Home-page: https://github.com/matrix-org/matrix-synapse-ldap3
+Author: hexa-
+Author-email: hexa@darmstadt.ccc.de
+License: UNKNOWN
+Description: Synapse LDAP Auth Provider
+ ==========================
+
+ Allows synapse to use LDAP as a password provider.
+
+ Installation
+ ------------
+ - Via deb package `python-matrix-synapse-ldap3` available in the same repo as the synapse package
+ - Via python's package manager: `pip install matrix-synapse-ldap3`
+
+ Usage
+ -----
+
+ Example synapse config:
+
+ .. code:: yaml
+
+ password_providers:
+ - module: "ldap_auth_provider.LdapAuthProvider"
+ config:
+ enabled: true
+ uri: "ldap://ldap.example.com:389"
+ start_tls: true
+ base: "ou=users,dc=example,dc=com"
+ attributes:
+ uid: "cn"
+ mail: "email"
+ name: "givenName"
+ #bind_dn:
+ #bind_password:
+ #filter: "(objectClass=posixAccount)"
+
+Platform: UNKNOWN
+Classifier: Development Status :: 4 - Beta
+Classifier: License :: OSI Approved :: Apache Software License
+Classifier: Programming Language :: Python :: 2.7
diff --git a/debian/patches/0002-document-debug-level.patch b/debian/patches/0002-document-debug-level.patch
new file mode 100644
index 0000000..eff40da
--- /dev/null
+++ b/debian/patches/0002-document-debug-level.patch
@@ -0,0 +1,56 @@
+From 7154e2f5e8c3786a3c60418f85144cbefbdcddd0 Mon Sep 17 00:00:00 2001
+From: Stephen Kent <smkent@smkent.net>
+Date: Thu, 9 Feb 2017 20:36:25 -0800
+Subject: [PATCH] Document how to set the matrix-synapse-ldap3 plugin log level
+ to DEBUG
+
+This implements #21
+---
+ README.rst | 34 ++++++++++++++++++++++++++++++++++
+ 1 file changed, 34 insertions(+)
+
+diff --git a/README.rst b/README.rst
+index 88f6440..be376fa 100644
+--- a/README.rst
++++ b/README.rst
+@@ -29,3 +29,37 @@ Example synapse config:
+ #bind_dn:
+ #bind_password:
+ #filter: "(objectClass=posixAccount)"
++
++Troubleshooting and Debugging
++-----------------------------
++
++``matrix-synapse-ldap3`` logging is included in the Synapse homeserver log
++(typically ``homeserver.log``). The LDAP plugin log level can be increased to
++``DEBUG`` for troubleshooting and debugging by making the following modifications
++to your Synapse server's logging configuration file:
++
++- Set the value for `handlers.file.level` to `DEBUG`:
++
++.. code:: yaml
++
++ handlers:
++ file:
++ # [...]
++ level: DEBUG
++
++- Add the following to the `loggers` section:
++
++.. code:: yaml
++
++ loggers:
++ # [...]
++ ldap3:
++ level: DEBUG
++ ldap_auth_provider:
++ level: DEBUG
++
++Finally, restart your Synapse server for the changes to take effect:
++
++.. code:: sh
++
++ synctl restart
+--
+2.11.0
+
diff --git a/debian/patches/series b/debian/patches/series
index a72cc06..f9deaf3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
0001-gracefully-handle-missing-email.patch
+0002-document-debug-level.patch
diff --git a/docs/README.rst b/docs/README.rst
deleted file mode 100644
index 88f6440..0000000
--- a/docs/README.rst
+++ /dev/null
@@ -1,31 +0,0 @@
-Synapse LDAP Auth Provider
-==========================
-
-Allows synapse to use LDAP as a password provider.
-
-Installation
-------------
-- Via deb package `python-matrix-synapse-ldap3` available in the same repo as the synapse package
-- Via python's package manager: `pip install matrix-synapse-ldap3`
-
-Usage
------
-
-Example synapse config:
-
-.. code:: yaml
-
- password_providers:
- - module: "ldap_auth_provider.LdapAuthProvider"
- config:
- enabled: true
- uri: "ldap://ldap.example.com:389"
- start_tls: true
- base: "ou=users,dc=example,dc=com"
- attributes:
- uid: "cn"
- mail: "email"
- name: "givenName"
- #bind_dn:
- #bind_password:
- #filter: "(objectClass=posixAccount)"
diff --git a/matrix_synapse_ldap3.egg-info/PKG-INFO b/matrix_synapse_ldap3.egg-info/PKG-INFO
new file mode 100644
index 0000000..58cfe1a
--- /dev/null
+++ b/matrix_synapse_ldap3.egg-info/PKG-INFO
@@ -0,0 +1,44 @@
+Metadata-Version: 1.1
+Name: matrix-synapse-ldap3
+Version: 0.1.2
+Summary: An LDAP3 auth provider for Synapse
+Home-page: https://github.com/matrix-org/matrix-synapse-ldap3
+Author: hexa-
+Author-email: hexa@darmstadt.ccc.de
+License: UNKNOWN
+Description: Synapse LDAP Auth Provider
+ ==========================
+
+ Allows synapse to use LDAP as a password provider.
+
+ Installation
+ ------------
+ - Via deb package `python-matrix-synapse-ldap3` available in the same repo as the synapse package
+ - Via python's package manager: `pip install matrix-synapse-ldap3`
+
+ Usage
+ -----
+
+ Example synapse config:
+
+ .. code:: yaml
+
+ password_providers:
+ - module: "ldap_auth_provider.LdapAuthProvider"
+ config:
+ enabled: true
+ uri: "ldap://ldap.example.com:389"
+ start_tls: true
+ base: "ou=users,dc=example,dc=com"
+ attributes:
+ uid: "cn"
+ mail: "email"
+ name: "givenName"
+ #bind_dn:
+ #bind_password:
+ #filter: "(objectClass=posixAccount)"
+
+Platform: UNKNOWN
+Classifier: Development Status :: 4 - Beta
+Classifier: License :: OSI Approved :: Apache Software License
+Classifier: Programming Language :: Python :: 2.7
diff --git a/matrix_synapse_ldap3.egg-info/SOURCES.txt b/matrix_synapse_ldap3.egg-info/SOURCES.txt
new file mode 100644
index 0000000..5f83410
--- /dev/null
+++ b/matrix_synapse_ldap3.egg-info/SOURCES.txt
@@ -0,0 +1,15 @@
+LICENSE
+MANIFEST.in
+README.rst
+ldap_auth_provider.py
+requirements.txt
+setup.cfg
+setup.py
+tox.ini
+matrix_synapse_ldap3.egg-info/PKG-INFO
+matrix_synapse_ldap3.egg-info/SOURCES.txt
+matrix_synapse_ldap3.egg-info/dependency_links.txt
+matrix_synapse_ldap3.egg-info/requires.txt
+matrix_synapse_ldap3.egg-info/top_level.txt
+tests/__init__.py
+tests/test_simple.py \ No newline at end of file
diff --git a/matrix_synapse_ldap3.egg-info/dependency_links.txt b/matrix_synapse_ldap3.egg-info/dependency_links.txt
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/matrix_synapse_ldap3.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/matrix_synapse_ldap3.egg-info/requires.txt b/matrix_synapse_ldap3.egg-info/requires.txt
new file mode 100644
index 0000000..061d0df
--- /dev/null
+++ b/matrix_synapse_ldap3.egg-info/requires.txt
@@ -0,0 +1,3 @@
+Twisted>=15.1.0
+ldap3
+service_identity
diff --git a/matrix_synapse_ldap3.egg-info/top_level.txt b/matrix_synapse_ldap3.egg-info/top_level.txt
new file mode 100644
index 0000000..8aa6316
--- /dev/null
+++ b/matrix_synapse_ldap3.egg-info/top_level.txt
@@ -0,0 +1 @@
+ldap_auth_provider
diff --git a/setup.cfg b/setup.cfg
index ab5366c..ee91fa4 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,4 +1,8 @@
[flake8]
max-line-length = 90
-# W503 requires that binary operators be at the end, not start, of lines. Erik doesn't like it.
ignore = W503
+
+[egg_info]
+tag_build =
+tag_date = 0
+
diff --git a/setup.py b/setup.py
index 19091d8..0972f42 100755
--- a/setup.py
+++ b/setup.py
@@ -55,4 +55,7 @@ setup(
'License :: OSI Approved :: Apache Software License',
'Programming Language :: Python :: 2.7',
],
+ maintainer="hexa-",
+ maintainer_email="hexa@darmstadt.ccc.de",
+ url="https://github.com/matrix-org/matrix-synapse-ldap3",
)