summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2017-06-28 10:04:20 +0000
committerintrigeri <intrigeri@boum.org>2017-06-28 10:04:20 +0000
commit96832542991ac43f71673952be5f636a6e955914 (patch)
treec99af03e9bf0cbd8eb52b4c1e8b87f3b70a2cc49
parent21fa7b32164a8e50bf547eb18460d1ad4fc2a8ac (diff)
Makefile: ensure we don't overwrite an existing tarball.
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c1f18e8..0c2846e 100644
--- a/Makefile
+++ b/Makefile
@@ -11,10 +11,12 @@ distclean: clean
rm -f metche.8
VERSION=$(shell head -n1 Changelog | awk '{print $$1}')
+TARBALL=../metche-$(VERSION).tar.gz
release: Changelog
+ ! [ -f $(TARBALL) ]
git archive \
--prefix=metche-$(VERSION)/ \
- --output=../metche-$(VERSION).tar.gz \
+ --output=$(TARBALL) \
master
.PHONY: all doc clean distclean