summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorintrigeri <intrigeri@boum.org>2017-06-28 07:53:06 +0000
committerintrigeri <intrigeri@boum.org>2017-06-28 07:53:06 +0000
commita9c8a479587e5128b87fa602a3bfebe46293afdc (patch)
tree663afc079302a5bdae78f3815cccafc9c48c717b
parenteb7142fc241b0ccf8741c9bffb8fe55a397a8980 (diff)
Add a Makefile target to create a new upstream release tarball.
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index bbbeb76..c1f18e8 100644
--- a/Makefile
+++ b/Makefile
@@ -10,4 +10,11 @@ clean:
distclean: clean
rm -f metche.8
+VERSION=$(shell head -n1 Changelog | awk '{print $$1}')
+release: Changelog
+ git archive \
+ --prefix=metche-$(VERSION)/ \
+ --output=../metche-$(VERSION).tar.gz \
+ master
+
.PHONY: all doc clean distclean