summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index bbbeb76..0c2846e 100644
--- a/Makefile
+++ b/Makefile
@@ -10,4 +10,13 @@ clean:
distclean: clean
rm -f metche.8
+VERSION=$(shell head -n1 Changelog | awk '{print $$1}')
+TARBALL=../metche-$(VERSION).tar.gz
+release: Changelog
+ ! [ -f $(TARBALL) ]
+ git archive \
+ --prefix=metche-$(VERSION)/ \
+ --output=$(TARBALL) \
+ master
+
.PHONY: all doc clean distclean