summaryrefslogtreecommitdiff
path: root/features/mkc_imp.f_strtoi.mk
diff options
context:
space:
mode:
Diffstat (limited to 'features/mkc_imp.f_strtoi.mk')
-rw-r--r--features/mkc_imp.f_strtoi.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/features/mkc_imp.f_strtoi.mk b/features/mkc_imp.f_strtoi.mk
new file mode 100644
index 0000000..e00aa74
--- /dev/null
+++ b/features/mkc_imp.f_strtoi.mk
@@ -0,0 +1,19 @@
+# Copyright (c) 2021 by Aleksey Cheusov
+#
+# See LICENSE file in the distribution.
+
+.ifndef _MKC_IMP_F_STRTOI_MK
+_MKC_IMP_F_STRTOI_MK := 1
+
+MKC_CHECK_FUNCS6 += strtoi:inttypes.h
+MKC_CHECK_FUNCLIBS += strtoi
+
+.include <mkc.conf.mk>
+
+.if ${HAVE_FUNCLIB.strtoi:U} != 1
+MKC_SRCS += ${FEATURESDIR}/strto/mkc_strtoi.c
+.endif
+
+CPPFLAGS += -D_MKC_CHECK_STRTOI
+
+.endif #_MKC_IMP_F_STRTOI_MK