summaryrefslogtreecommitdiff
path: root/scripts/mk-configure.7.in
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/mk-configure.7.in')
-rw-r--r--scripts/mk-configure.7.in88
1 files changed, 74 insertions, 14 deletions
diff --git a/scripts/mk-configure.7.in b/scripts/mk-configure.7.in
index afb42a2..8123ec6 100644
--- a/scripts/mk-configure.7.in
+++ b/scripts/mk-configure.7.in
@@ -18,7 +18,7 @@
.sp
..
.\" ------------------------------------------------------------------
-.TH MK-CONFIGURE 7 "Jan 05, 2021" "" ""
+.TH MK-CONFIGURE 7 "Jan 21, 2021" "" ""
.SH NAME
mk-configure \- lightweight replacement for GNU autotools
.SH DESCRIPTION
@@ -222,11 +222,12 @@ mipspro MIPSpro C compiler
C compiler version.
.RI < "I" >
.IP CCSTD
-C language standard required by program. Supported options:
+Add C language standard command line option to the compiler.
+Supported options:
.IR c89 ", " gnu89 " (C89 with GNU extensions), " c99 ", " gnu99 \
" (C99 with GNU extensions), " c11 ", " gnu11 " (C89 with GNU extensions), " \
c17 ", " gnu17 " (C17 with GNU extensions)."
-If compiler is not known for mk-configure developer or does not
+If compiler is not known for mk-configure or does not
support appropriate option, no additional options are applied.
.RI < M >
.RI [ "" ]
@@ -353,11 +354,13 @@ Additional flags to the compiler when creating C++ objects.
Similar to CXXOPTS but for project ${PROJECTNAME}.
.RI < "U" >
.IP CXXSTD
-C++ language standard required by program. Supported options:
-.IR c89 ", " gnu89 " (C89 with GNU extensions), " c99 ", " gnu99 \
-" (C99 with GNU extensions), " c11 ", " gnu11 " (C89 with GNU extensions), " \
-c17 ", " gnu17 " (C17 with GNU extensions)."
-If compiler is not known for mk-configure developer or does not
+Add C++ language standard command line option to the compiler and linker.
+Supported options:
+.IR c++98 ", " gnu++98 " (C++98 with GNU extensions), "
+.IR c++11 ", " gnu++11 " (C++11 with GNU extensions), "
+.IR c++14 ", " gnu++14 " (C++14 with GNU extensions), "
+.IR c++17 ", " gnu++17 " (C++17 with GNU extensions)"
+If compiler is not known for mk-configure or does not
support appropriate option, no additional options are applied.
.RI < M >
.RI [ "" ]
@@ -876,7 +879,8 @@ See LIBDEPS in section
.BR mk.subprj.mk .
.IP EXPORT_SYMBOLS
Only symbols listed in a specified file (one symbol per line) are
-exported. This variable has no effect on some platforms. By default
+exported. Empty lines and comments started with # symbol
+are ignored. This variable has no effect on some platforms. By default
all symbols are exported.
.RI < "M" >
[]
@@ -1388,7 +1392,7 @@ is "yes", equivalent define leads to the same results.
MKC_CHECK_FUNCS1 += htobe32:sys/endian.h
MKC_FUNC_OR_DEFINE.htobe32 += yes
Res: HAVE_FUNC2.fgetln.stdio_h = 1
- HAVE_FUNC6.pselect.sys.select_h = 1
+ HAVE_FUNC6.pselect.sys_select_h = 1
HAVE_FUNC1.htobe32.sys_endian_h=1
CFLAGS += -DHAVE_FUNC2_FGETLN_STDIO_H=1 \\
+= -DHAVE_FUNC6_PSELECT_SYS_SELECT_H=1 \\
@@ -1620,10 +1624,11 @@ functions available in *BSD.
.B dprintf
This feature provides dprintf(3).
.TP
-.B efunc
-This feature provides esetfunc(3), efopen(3), ecalloc(3),
-emalloc(3), erealloc(3), estrdup(3), estrndup(3), estrlcpy(3),
-estrlcat(3), easprintf(3), and evasprintf(3) functions from NetBSD.
+.B efun
+This feature provides esetfunc(3), efopen(3), ecalloc(3), emalloc(3),
+erealloc(3), ereallocarr(3), estrdup(3), estrndup(3), estrlcpy(3),
+estrlcat(3), easprintf(3), estrtoi(3), estrtou(3)
+and evasprintf(3) functions from NetBSD.
.TP
.B err
This feature provides err(3), errx(3), verr(3) and verrx(3) BSD-isms.
@@ -1634,6 +1639,9 @@ This feature provides errc(3) and verrc(3) BSD-isms.
.B fgetln
This feature provides fgetln(3) BSD-ism.
.TP
+.B fparseln
+This feature provides fparseln(3) BSD-ism.
+.TP
.B fts
This feature provides fts_open(3), fts_read(3) etc. functions
available on BSDs and Linux. If it is absent on your system,
@@ -1670,6 +1678,37 @@ LDADD. Most UNIX-like systems have libm but Haiku, for example, does
not. mkc_imp.f_libm.mk checks whether libm library is available and if yes,
-lm is added to LDADD.
.TP
+.B macro
+This feature provides the following macro stolen from NetBSD.
+.I __aligned(x)
+defined as
+.I "__attribute__((aligned(x)))"
+if supported by compiler,
+.I __always_inline
+defined as
+.I "__attribute__((always_inline))"
+if supported by compiler,
+.I __arraycount(a)
+defined as
+.I "(sizeof(__a)/sizeof(__a[0]))",
+.I __constfunc
+defined as
+.I "__attribute__((const))"
+if supported by compiler,
+.I __dead
+defined as
+.I "__attribute__((noreturn))"
+if supported by compiler,
+.IR "MIN(a,b)" " and " "MAX(a,b),"
+.I __pure
+defined as
+.I "__attribute__((pure))"
+if supported by compiler,
+.I "__printflike(n,m)"
+defined as
+.I "__attribute__((format (printf, n, m)))"
+if supported by compiler.
+.TP
.B posix_getopt
It is well-known that glibc getopt(3) does not conform to POSIX by default.
This feature provides POSIX-ly correct getopt.
@@ -1692,6 +1731,12 @@ sys/tree.h and appropriate macroses are available. If yes, mkc_RB.h
and mkc_SPLAY.h include system-wide sys/tree.h, otherwise NetBSD
version of sys/tree.h provided by mk-configure is included.
.TP
+.B reallocarr
+This feature provides reallocarr(3) function from NetBSD.
+.TP
+.B reallocarray
+This feature provides reallocarray(3) function from OpenBSD.
+.TP
.B shquote
This feature provides shquote(3) function from NetBSD.
.TP
@@ -1719,6 +1764,21 @@ This feature provides strndup(3) from POSIX.
.B strsep
This features provides strsep(3) and stresep(3) functions.
.TP
+.B strtoi
+This feature provides strtoi(3) function
+introduced in NetBSD.
+.TP
+.B strtou
+This feature provides strtoi(3) function
+introduced in NetBSD.
+.TP
+.B vis
+This feature provides vis(3), nvis(3), svis(3), snvis(3), strvis(3),
+strnvis(3), strsvis(3), strsnvis(3), strvisx(3), strnvisx(3),
+strenvisx(3), strsvisx(3), strsnvisx(3), strsenvisx(3),
+strunvis(3), strnunvis(3), strunvisx(3), strnunvisx(3) and
+unvis(3) from NetBSD.
+.TP
.B warn
This feature provides warn(3), warnx(3), vwarn(3) and vwarnx(3) BSD-isms.
.RE