summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2021-12-12 16:58:57 -0300
committerRafael Laboissière <rafael@debian.org>2021-12-12 18:02:37 -0300
commit777fc843bbf5e6e226c3fac36266a2117fd64cd3 (patch)
treeb30c210a5af38b7f08c1406b03b1b7a282ad8c2e
parent2475e4c9dc3e59145ae84565b6d0bb35e3863234 (diff)
d/rules: Install the python3.* extension to the correct path
Thanks: Steve Langasek for the patch Closes: #1001363
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index dde1e5b..ce2e465 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,7 @@ override_dh_python3-arch:
distdir=debian/python3-nlopt/usr/lib/python3/dist-packages; \
mkdir -p $$distdir; \
for py3alt in $(PY3_ALT); do \
- py3short=`echo $${py3alt} | sed "s/\.//g"`; \
+ py3short=`echo $${py3alt} | sed "s/\.//g"`-`dpkg-architecture -qDEB_HOST_MULTIARCH`; \
cp $(BUILDDIR)-python$${py3alt}/src/swig/_nlopt.so $$distdir/_nlopt.cpython-$${py3short}.so; \
chrpath -d $$distdir/_nlopt.cpython-$${py3short}.so; \
done