summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-10 23:54:10 +0100
committerJohannes Schauer Marin Rodrigues <josch@debian.org>2021-12-10 23:54:10 +0100
commit80cd6cadb21c0d221e7a1b2d974c1fd8c4182837 (patch)
treeef7781854fa4444a02d75d91e4a36491ebff1b1e
parent08b2a6a5933ace70efbd892d1329013ae31cb8df (diff)
yaml.safeLoad is removed in js-yaml 4. Use yaml.load instead
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/yaml.patch11
3 files changed, 13 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index c6abdd8..b65ed66 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
node-carto (1.2.0-2) UNRELEASED; urgency=medium
* debian/salsa-ci.yml: disable aptly
+ * yaml.safeLoad is removed in js-yaml 4. Use yaml.load instead
-- Johannes Schauer Marin Rodrigues <josch@debian.org> Fri, 10 Dec 2021 23:06:37 +0100
diff --git a/debian/patches/series b/debian/patches/series
index c66bb56..0b11e4c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
disable-eslint.patch
fix-tests.patch
+yaml.patch
diff --git a/debian/patches/yaml.patch b/debian/patches/yaml.patch
new file mode 100644
index 0000000..6eacc88
--- /dev/null
+++ b/debian/patches/yaml.patch
@@ -0,0 +1,11 @@
+--- a/lib/carto/mml.js
++++ b/lib/carto/mml.js
+@@ -22,7 +22,7 @@ carto.MML.prototype.load = function load
+ env = {};
+
+ try {
+- mml = yaml.safeLoad(data);
++ mml = yaml.load(data);
+ } catch (err) {
+ env = {};
+ util.error(env, {