summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPirate Praveen <praveen@debian.org>2020-12-15 00:26:30 +0530
committerPirate Praveen <praveen@debian.org>2020-12-15 00:26:30 +0530
commit4c7e3ff75093a70c1465d456d74a7202789e5b45 (patch)
tree9157a497872d28b4ee6a5a19f7c240439c4a42e8
parentae2b0c65f68ececb4264f0c7d1bceeae4f450c7b (diff)
Use node-rollup-plugin-terser (now available in the archive)
-rw-r--r--debian/control2
-rw-r--r--debian/patches/remove-unsupported-syntax.patch32
-rw-r--r--debian/patches/reproducible_build.diff2
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
5 files changed, 2 insertions, 39 deletions
diff --git a/debian/control b/debian/control
index c16f252..6500a2a 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
, pkg-js-tools
, node-tape
, rollup
- , uglifyjs.terser
+ , node-rollup-plugin-terser
, node-d3-array
Standards-Version: 4.5.1
Homepage: https://d3js.org/d3-collection/
diff --git a/debian/patches/remove-unsupported-syntax.patch b/debian/patches/remove-unsupported-syntax.patch
deleted file mode 100644
index bf1b359..0000000
--- a/debian/patches/remove-unsupported-syntax.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-This syntax is not supported in packaged rollup/node yet.
-Minified file is generated by uglifyjs.terser command line.
-
---- a/rollup.config.js
-+++ b/rollup.config.js
-@@ -1,4 +1,3 @@
--import {terser} from "rollup-plugin-terser";
- import * as meta from "./package.json";
-
- const config = {
-@@ -17,20 +16,5 @@
- };
-
- export default [
-- config,
-- {
-- ...config,
-- output: {
-- ...config.output,
-- file: `dist/${meta.name}.min.js`
-- },
-- plugins: [
-- ...config.plugins,
-- terser({
-- output: {
-- preamble: config.output.banner
-- }
-- })
-- ]
-- }
-+ config
- ];
diff --git a/debian/patches/reproducible_build.diff b/debian/patches/reproducible_build.diff
index 289e06d..2f690be 100644
--- a/debian/patches/reproducible_build.diff
+++ b/debian/patches/reproducible_build.diff
@@ -4,7 +4,7 @@ Last-Update: 2019-06-20
--- a/rollup.config.js
+++ b/rollup.config.js
-@@ -9,7 +9,7 @@
+@@ -10,7 +10,7 @@
format: "umd",
indent: false,
extend: true,
diff --git a/debian/patches/series b/debian/patches/series
index ba4f208..774a9a2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
-remove-unsupported-syntax.patch
reproducible_build.diff
diff --git a/debian/rules b/debian/rules
index 975ed57..65b73e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,8 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
%:
dh $@ --with nodejs
override_dh_auto_build:
rollup -c
- uglifyjs.terser dist/d3-collection.js -o dist/d3-collection.min.js