summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPirate Praveen <praveen@debian.org>2020-12-16 01:32:10 +0530
committerPirate Praveen <praveen@debian.org>2020-12-16 01:32:10 +0530
commit897051668ae6f6d41888b98113671321201257e3 (patch)
tree26aaad68454392ae2587f5a67758f4b0d8cba289
parent72b312fc3a9f9f61e8dd73a2f23425381592c5ff (diff)
Use node-rollup-plugin-terser (now available in the archive)
-rw-r--r--debian/control2
-rw-r--r--debian/patches/remove-unsupported-syntax.patch32
-rw-r--r--debian/patches/reproducible_build.diff2
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
5 files changed, 2 insertions, 39 deletions
diff --git a/debian/control b/debian/control
index 9cf325e..c6c4ed8 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Build-Depends:
, nodejs
, pkg-js-tools
, rollup
- , uglifyjs.terser
+ , node-rollup-plugin-terser
, node-tape
Standards-Version: 4.5.1
Homepage: https://d3js.org/d3-polygon/
diff --git a/debian/patches/remove-unsupported-syntax.patch b/debian/patches/remove-unsupported-syntax.patch
deleted file mode 100644
index bf1b359..0000000
--- a/debian/patches/remove-unsupported-syntax.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-This syntax is not supported in packaged rollup/node yet.
-Minified file is generated by uglifyjs.terser command line.
-
---- a/rollup.config.js
-+++ b/rollup.config.js
-@@ -1,4 +1,3 @@
--import {terser} from "rollup-plugin-terser";
- import * as meta from "./package.json";
-
- const config = {
-@@ -17,20 +16,5 @@
- };
-
- export default [
-- config,
-- {
-- ...config,
-- output: {
-- ...config.output,
-- file: `dist/${meta.name}.min.js`
-- },
-- plugins: [
-- ...config.plugins,
-- terser({
-- output: {
-- preamble: config.output.banner
-- }
-- })
-- ]
-- }
-+ config
- ];
diff --git a/debian/patches/reproducible_build.diff b/debian/patches/reproducible_build.diff
index 289e06d..2f690be 100644
--- a/debian/patches/reproducible_build.diff
+++ b/debian/patches/reproducible_build.diff
@@ -4,7 +4,7 @@ Last-Update: 2019-06-20
--- a/rollup.config.js
+++ b/rollup.config.js
-@@ -9,7 +9,7 @@
+@@ -10,7 +10,7 @@
format: "umd",
indent: false,
extend: true,
diff --git a/debian/patches/series b/debian/patches/series
index ba4f208..774a9a2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1 @@
-remove-unsupported-syntax.patch
reproducible_build.diff
diff --git a/debian/rules b/debian/rules
index 049a86d..65b73e2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,8 @@
#!/usr/bin/make -f
# -*- makefile -*-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
%:
dh $@ --with nodejs
override_dh_auto_build:
rollup -c
- uglifyjs.terser dist/d3-polygon.js -o dist/d3-polygon.min.js