summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2015-04-26 10:49:40 +0000
committerJelmer Vernooij <jelmer@samba.org>2015-04-26 10:49:40 +0000
commit14c56a7547da6e4f38c14c97bba419e3e890d50f (patch)
treeae6c7ff699ee7271c66809fa1e12aaba07f0ee45
parent657fe3b2c1f90375be9a4dd480f16362531d8b82 (diff)
Use -Wl,--as-needed when linking.
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7b1633e..a678a35 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ ntdb (1.0-6) UNRELEASED; urgency=medium
* debian/copyright: Add short license names, paragraph for main files.
* Bump standards version to 3.9.6 (no changes).
+ * Use -Wl,--as-needed when linking.
-- Jelmer Vernooij <jelmer@debian.org> Sun, 26 Apr 2015 10:28:58 +0000
diff --git a/debian/rules b/debian/rules
index 90d05d3..7ec3419 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@ CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
CFLAGS += -g -Wall
-SHLD_FLAGS += -shared -Wl,--as-needed
+LD_FLAGS += -shared -Wl,--as-needed
DESTDIR=$(CURDIR)/debian/tmp
export PYTHON=$(shell which `pyversions -d`)
@@ -28,7 +28,7 @@ override_dh_python2:
dh_python2 --no-guessing-versions
override_dh_auto_build:
- $(MAKE) all SHLD_FLAGS="$(SHLD_FLAGS)"
+ $(MAKE) all
override_dh_auto_test:
echo "Testsuite disabled, since it currently requires developer mode."