summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2013-11-15 22:39:50 +0000
committerJelmer Vernooij <jelmer@samba.org>2013-11-15 22:39:50 +0000
commit882f90ba35f5fc3db3a914b5ba8843a9948ad0c6 (patch)
tree1a87f164d41649bc73964529dfc63a1643b3ad58
parenta8d743fe4abf91b90f20179fbb79593429dd88cc (diff)
Disable testing, as it requires developer mode.
-rwxr-xr-xdebian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index aba7a96..90d05d3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,9 +31,10 @@ override_dh_auto_build:
$(MAKE) all SHLD_FLAGS="$(SHLD_FLAGS)"
override_dh_auto_test:
-ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- $(MAKE) check
-endif
+ echo "Testsuite disabled, since it currently requires developer mode."
+#ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+# $(MAKE) check
+#endif
override_dh_auto_clean:
[ ! -f Makefile ] || $(MAKE) distclean
@@ -50,7 +51,7 @@ override_dh_auto_clean:
override_dh_auto_install:
$(MAKE) install DESTDIR=$(DESTDIR)
# Waf should be doing this..
- ar cr libntdb.a bin/default/common/*.o
+ ar cr libntdb.a bin/default/*.o bin/default/lib/ccan/*/*.o
mv libntdb.a $(DESTDIR)/usr/lib/$(DEB_HOST_MULTIARCH)
override_dh_strip: