summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 2 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index 2d98311..91ce70b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,19 +1,7 @@
#!/usr/bin/make -f
-
-# Uncomment this to turn on verbose mode.
-# export DH_VERBOSE=1
-# export DH_OPTIONS=-v
-
-DESTDIR=$(CURDIR)/debian/tmp
+# -*- makefile -*-
include /usr/share/ocaml/ocamlvars.mk
%:
- dh $@ --with ocaml
-
-override_dh_auto_build:
- dune build -p benchmark
-
-override_dh_auto_install:
- dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=$(OCAML_STDLIB_DIR)
- rm -f $(DESTDIR)/usr/doc/benchmark/LICENSE.md
+ dh $@ --with ocaml --buildsystem ocaml_dune