summaryrefslogtreecommitdiff
path: root/rules
diff options
context:
space:
mode:
Diffstat (limited to 'rules')
-rwxr-xr-xrules18
1 files changed, 18 insertions, 0 deletions
diff --git a/rules b/rules
new file mode 100755
index 0000000..1823e88
--- /dev/null
+++ b/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+include /usr/share/ocaml/ocamlvars.mk
+
+DESTDIR=$(CURDIR)/debian/tmp
+
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_build:
+ dune build -p sexplib0
+
+override_dh_auto_install:
+ dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=$(OCAML_STDLIB_DIR)
+ rm -f $(DESTDIR)/usr/doc/sexplib0/LICENSE.md
+
+override_dh_dwz: