summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefano Zacchiroli <zack@debian.org>2009-10-06 15:36:30 +0200
committerStéphane Glondu <glondu@debian.org>2024-03-19 11:11:20 +0100
commitbd119578f941ffb37b11da18f319e6a2cbb86aa3 (patch)
tree1741c5d8e92ea2c106bcd224ab36a7e7840faa19
parent209909adad6dac95f0e087f5e0d4206dcc043623 (diff)
Create installation directories
...since ocamlfind doesn't Signed-off-by: Stefano Zacchiroli <zack@debian.org> Gbp-Pq: Name 0002-Create-installation-directories.patch
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f0c33a01..3f31036b 100644
--- a/Makefile
+++ b/Makefile
@@ -55,6 +55,7 @@ tools:
# The following PHONY rule is important for Cygwin:
.PHONY: install
install:
+ mkdir -p $(DESTDIR) $(OCAMLFIND_DESTDIR) $(OCAMLFIND_DESTDIR)/stublibs
for pkg in $(PKGLIST); do \
( cd src/$$pkg && $(MAKE) -f Makefile.pre install ) || exit; \
done