summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephane Glondu <steph@glondu.net>2023-08-09 13:47:17 +0200
committerStephane Glondu <steph@glondu.net>2023-08-09 13:48:04 +0200
commitc26d7ecb2649fcd89afe2fa933726a42aaa451c6 (patch)
treee819896cd666f06739d34f3467452cefeb28cd90
parentbd7f49e8069baddc8cc29aa021dbae84632a61c8 (diff)
Update packaging
-rw-r--r--debian/compat1
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules18
3 files changed, 17 insertions, 12 deletions
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index 9f9bf3e..328145f 100644
--- a/debian/control
+++ b/debian/control
@@ -3,12 +3,12 @@ Priority: optional
Maintainer: Debian OCaml Maintainers <debian-ocaml-maint@lists.debian.org>
Uploaders: Stéphane Glondu <glondu@debian.org>
Build-Depends:
- cdbs,
- debhelper (>= 10),
- dh-ocaml (>= 0.9),
+ debhelper-compat (= 13),
+ dh-ocaml,
libpam-dev,
- ocaml-nox (>= 3.11.1-3~)
-Standards-Version: 3.8.3
+ ocaml
+Standards-Version: 4.6.2
+Rules-Requires-Root: no
Section: ocaml
Homepage: http://sharvil.nanavati.net/projects/ocamlpam/
Vcs-Browser: https://salsa.debian.org/ocaml-team/ocamlpam
diff --git a/debian/rules b/debian/rules
index 7b6bc47..ebd900f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,9 @@
#!/usr/bin/make -f
# -*- makefile -*-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/rules/ocaml.mk
-PKGNAME = libpam-ocaml-dev
+include /usr/share/ocaml/ocamlvars.mk
+
DESTDIR := $(CURDIR)/debian/tmp$(OCAML_STDLIB_DIR)
-DOCDIR = $(CURDIR)/debian/doc/html
-OCAML_OCAMLDOC_PACKAGES = $(OCAML_LIBDEV_PACKAGES)
DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DESTDIR)
DEB_MAKE_BUILD_TARGET = META byte
@@ -15,3 +11,13 @@ DEB_MAKE_BUILD_TARGET = META byte
ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
DEB_MAKE_BUILD_TARGET += opt
endif
+
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_build:
+ $(MAKE) $(DEB_MAKE_BUILD_TARGET)
+
+override_dh_auto_install:
+ mkdir -p $(DESTDIR)
+ $(MAKE) $(DEB_MAKE_INSTALL_TARGET)