summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 1 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index ef3411f..9cf84c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,21 +3,10 @@
include /usr/share/ocaml/ocamlvars.mk
-DESTDIR=$(CURDIR)/debian/tmp
-
%:
- dh $@ --with ocaml
-
-override_dh_auto_build:
- dune build -p ocplib-endian
-
-override_dh_auto_install:
- dune install --destdir=$(DESTDIR) --prefix=/usr --libdir=..$(OCAML_STDLIB_DIR)
- rm -f $(DESTDIR)/usr/doc/ocplib-endian/COPYING.txt
+ dh $@ --with ocaml --buildsystem ocaml_dune
override_dh_auto_test:
ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
dh_auto_test
endif
-
-override_dh_dwz: