summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2024-01-06 18:56:14 -0300
committerRafael Laboissière <rafael@debian.org>2024-01-06 18:56:14 -0300
commit11d9055615a32c19aece0a05f490a95d0c1baca5 (patch)
tree36b3cf4f95c3f369fd230832c1ed3c7ed996a558
parent585e67b9a28964125d68366a6e819a0c5d643244 (diff)
d/rules: Simplify rule for building the documentation
-rwxr-xr-xdebian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 290d9c5..eb40e9f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,9 +9,10 @@ export DEB_BUILD_MAINT_OPTIONS = nocheck
dh $@ --buildsystem=octave
ifeq (,$(filter nodoc,$(DEB_BUILD_OPTIONS)))
+TEXISRC = arduino.texi
execute_before_dh_auto_build:
- ( cd doc ; \
- makeinfo --no-split arduino.texi ; \
- makeinfo --html --no-split arduino.texi ; \
- texi2pdf arduino.texi || true )
+ cd doc ; \
+ makeinfo --no-split $(TEXISRC) ; \
+ makeinfo --html --no-split $(TEXISRC) ; \
+ texi2pdf --clean $(TEXISRC)
endif