summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Laboissière <rafael@debian.org>2021-11-14 13:59:42 -0300
committerRafael Laboissière <rafael@debian.org>2021-11-14 14:06:49 -0300
commitf8f37c71fb466dda44fe5bba0bf0d9b140e2be5a (patch)
treecce3817d831e5b1e08165dce78fa40c435551633
parentd200a789ab448a4ce70d1ac6718787a483732db0 (diff)
d/p/honor-cflags-cxxflags.patch: New patch
-rw-r--r--debian/patches/honor-cflags-cxxflags.patch23
-rw-r--r--debian/patches/series1
2 files changed, 24 insertions, 0 deletions
diff --git a/debian/patches/honor-cflags-cxxflags.patch b/debian/patches/honor-cflags-cxxflags.patch
new file mode 100644
index 0000000..dd30d5a
--- /dev/null
+++ b/debian/patches/honor-cflags-cxxflags.patch
@@ -0,0 +1,23 @@
+Description: Honor the environment variable CFLAGS and CXXFLAGS
+ This is required in Debian, such that hardening flags like
+ -fstack-protector-strong, -Wformat, and -Werror=format-security are
+ used in the compilation of C++ files.
+Author: Rafael Laboissière <rafael@debian.org>
+Forwarded: https://savannah.gnu.org/bugs/index.php?61483
+Last-Update: 2021-11-14
+
+--- octave-octclip-2.0.1.orig/src/Makefile
++++ octave-octclip-2.0.1/src/Makefile
+@@ -6,10 +6,10 @@ FLAGSCOMW=-Wall -Wextra -Wshadow -Wcast-
+ #Common optimization flags for C and C++
+ FLAGSCOMO=-O2 -funroll-loops -fno-common -fshort-enums
+ #Flags for C
+-CFLAGS=-std=c99 -pedantic $(FLAGSCOMW) -Wconversion -Wmissing-prototypes
++CFLAGS+=-std=c99 -pedantic $(FLAGSCOMW) -Wconversion -Wmissing-prototypes
+ CFLAGS+=-Wstrict-prototypes -Wnested-externs $(FLAGSCOMO)
+ #Flags for C++
+-CXXFLAGS=$(FLAGSCOMW) $(FLAGSCOMO)
++CXXFLAGS+=$(FLAGSCOMW) $(FLAGSCOMO)
+ #Export flags for compilers and linker
+ export CFLAGS CXXFLAGS
+
diff --git a/debian/patches/series b/debian/patches/series
index 6d05119..3c3b856 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
do-not-strip-debugging-symbols.patch
spelling-doc-oc-polybool.patch
+honor-cflags-cxxflags.patch