summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Weber <tweber@debian.org>2023-09-30 10:35:07 -0300
committerRafael Laboissière <rafael@debian.org>2023-09-30 10:35:07 -0300
commitccd04788bfeeeed6ac4d00b27f163e7e1d0073eb (patch)
tree1beda37f9ecf4933c1c345c460e74dc1a255c1d1
parent504c37b6816ad91aaec2129a6e75d06f719e2631 (diff)
Do not install versioned binaries
Forwarded: not-needed Reviewed-by: Rafael Laboissière <rafael@debian.org> Last-Update: 2016-11-20 We don't need them. Gbp-Pq: Name drop_versioned_binaries.patch
-rw-r--r--scripts/miscellaneous/mkoctfile.m2
-rw-r--r--scripts/pkg/private/configure_make.m6
-rw-r--r--src/main.in.cc2
-rw-r--r--src/module.mk2
4 files changed, 6 insertions, 6 deletions
diff --git a/scripts/miscellaneous/mkoctfile.m b/scripts/miscellaneous/mkoctfile.m
index be29b0c32..dcb92f469 100644
--- a/scripts/miscellaneous/mkoctfile.m
+++ b/scripts/miscellaneous/mkoctfile.m
@@ -212,7 +212,7 @@ function [output, status] = mkoctfile (varargin)
ext = __octave_config_info__ ("EXEEXT");
shell_script = fullfile (bindir,
- sprintf ("mkoctfile-%s%s", OCTAVE_VERSION, ext));
+ "mkoctfile");
if (! exist (shell_script, "file"))
__gripe_missing_component__ ("mkoctfile", "mkoctfile");
diff --git a/scripts/pkg/private/configure_make.m b/scripts/pkg/private/configure_make.m
index 085135f4e..c464800c4 100644
--- a/scripts/pkg/private/configure_make.m
+++ b/scripts/pkg/private/configure_make.m
@@ -37,10 +37,10 @@ function configure_make (desc, packdir, verbose)
ver = version ();
ext = __octave_config_info__ ("EXEEXT");
mkoctfile_program = fullfile (octave_bindir, ...
- sprintf ("mkoctfile-%s%s", ver, ext));
+ "mkoctfile");
octave_config_program = fullfile (octave_bindir, ...
- sprintf ("octave-config-%s%s", ver, ext));
- octave_binary = fullfile (octave_bindir, sprintf ("octave-%s%s", ver, ext));
+ "octave-config");
+ octave_binary = fullfile (octave_bindir, "octave");
if (! exist (mkoctfile_program, "file"))
__gripe_missing_component__ ("pkg", "mkoctfile");
diff --git a/src/main.in.cc b/src/main.in.cc
index 07e4d93f1..f43df629d 100644
--- a/src/main.in.cc
+++ b/src/main.in.cc
@@ -260,7 +260,7 @@ main (int argc, char **argv)
std::string octave_bindir = get_octave_bindir ();
std::string octave_archlibdir = get_octave_archlibdir ();
std::string octave_cli
- = octave_bindir + dir_sep_char + "octave-cli-" OCTAVE_VERSION;
+ = octave_bindir + dir_sep_char + "octave-cli";
std::string octave_gui = octave_archlibdir + dir_sep_char + "octave-gui";
#if defined (HAVE_OCTAVE_QT_GUI)
diff --git a/src/module.mk b/src/module.mk
index c916332fe..50473fd64 100644
--- a/src/module.mk
+++ b/src/module.mk
@@ -219,7 +219,7 @@ endif
ALL_LOCAL_TARGETS += $(OCTAVE_CROSS_TOOLS)
-install-exec-hook: make-version-links
+install-exec-hook:
uninstall-local: remove-version-links