summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GNUmakefile1
-rw-r--r--Makefile39
-rw-r--r--debian/Makefile.plb9
-rw-r--r--debian/changelog10
-rw-r--r--debian/control10
-rw-r--r--debian/patches/auto-gitignore2
-rw-r--r--debian/patches/makefile_update_for_kfreebsd_and_hurd91
-rw-r--r--debian/patches/pd-lib-builder.patch11
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules15
10 files changed, 46 insertions, 144 deletions
diff --git a/GNUmakefile b/GNUmakefile
new file mode 100644
index 0000000..91b305f
--- /dev/null
+++ b/GNUmakefile
@@ -0,0 +1 @@
+include debian/Makefile.plb
diff --git a/Makefile b/Makefile
index d47660a..a262f4b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-## Pd library template version 1.0.6
+## Pd library template version 1.0.4
# For instructions on how to use this template, see:
# http://puredata.info/docs/developer/MakefileTemplate
LIBRARY_NAME = bassemu~
@@ -31,8 +31,7 @@ EXTRA_DIST = miniseq.pd Makefile.nt
#
#------------------------------------------------------------------------------#
-# -I"$(PD_INCLUDE)/pd" supports the header location for 0.43
-CFLAGS = -I"$(PD_INCLUDE)/pd" -Wall -W -g
+CFLAGS = -DPD -I"$(PD_INCLUDE)" -Wall -W -g
LDFLAGS =
LIBS =
@@ -45,7 +44,7 @@ LIBS =
# get library version from meta file
LIBRARY_VERSION = $(shell sed -n 's|^\#X text [0-9][0-9]* [0-9][0-9]* VERSION \(.*\);|\1|p' $(LIBRARY_NAME)-meta.pd)
-CFLAGS += -DPD -DVERSION='"$(LIBRARY_VERSION)"'
+CFLAGS += -DVERSION='"$(LIBRARY_VERSION)"'
PD_INCLUDE = $(PD_PATH)/include
# where to install the library, overridden below depending on platform
@@ -122,34 +121,6 @@ ifeq ($(UNAME),Linux)
STRIP = strip --strip-unneeded -R .note -R .comment
DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
endif
-ifeq ($(UNAME),GNU)
- # GNU/Hurd, should work like GNU/Linux for basically all externals
- CPU := $(shell uname -m)
- SOURCES += $(SOURCES_linux)
- EXTENSION = pd_linux
- OS = linux
- PD_PATH = /usr
- OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
- CFLAGS += -fPIC
- LDFLAGS += -Wl,--export-dynamic -shared -fPIC
- LIBS += -lc
- STRIP = strip --strip-unneeded -R .note -R .comment
- DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
-endif
-ifeq ($(UNAME),GNU/kFreeBSD)
- # Debian GNU/kFreeBSD, should work like GNU/Linux for basically all externals
- CPU := $(shell uname -m)
- SOURCES += $(SOURCES_linux)
- EXTENSION = pd_linux
- OS = linux
- PD_PATH = /usr
- OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
- CFLAGS += -fPIC
- LDFLAGS += -Wl,--export-dynamic -shared -fPIC
- LIBS += -lc
- STRIP = strip --strip-unneeded -R .note -R .comment
- DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
-endif
ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
CPU := $(shell uname -m)
SOURCES += $(SOURCES_cygwin)
@@ -169,7 +140,7 @@ ifeq (MINGW,$(findstring MINGW,$(UNAME)))
EXTENSION = dll
OS = windows
PD_PATH = $(shell cd "$(PROGRAMFILES)"/pd && pwd)
- OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
+ OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -march=i686 -mtune=pentium4
CFLAGS += -mms-bitfields
LDFLAGS += -s -shared -Wl,--enable-auto-import
LIBS += -L"$(PD_PATH)/src" -L"$(PD_PATH)/bin" -L"$(PD_PATH)/obj" -lpd -lwsock32 -lkernel32 -luser32 -lgdi32
@@ -178,7 +149,7 @@ ifeq (MINGW,$(findstring MINGW,$(UNAME)))
endif
# in case somebody manually set the HELPPATCHES above
-HELPPATCHES ?= $(SOURCES:.c=-help.pd) $(PDOBJECTS:.pd=-help.pd)
+HELPPATCHES ?= $(SOURCES:.c=-help.pd) $(PDOBJECTS:.c=-help.pd)
CFLAGS += $(OPT_CFLAGS)
diff --git a/debian/Makefile.plb b/debian/Makefile.plb
new file mode 100644
index 0000000..891167f
--- /dev/null
+++ b/debian/Makefile.plb
@@ -0,0 +1,9 @@
+lib.name = bassemu~
+class.sources = bassemu~.c
+datafiles = \
+ $(wildcard *.pd) \
+ $(wildcard *.txt) \
+ $(empty)
+
+PDLIBBUILDER_DIR=/usr/share/pd-lib-builder
+include $(PDLIBBUILDER_DIR)/Makefile.pdlibbuilder
diff --git a/debian/changelog b/debian/changelog
index 4ae6074..2c4098e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+pd-bassemu (0.3-11) unstable; urgency=medium
+
+ * Re-build for both single and double-precision Pd
+ * Switch build-system to pd-lib-builder
+ + Replace upstream build-system with pd-lib-builder
+ + Drop obsolete patches
+ * Bump standards version to 4.6.2
+
+ -- IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org> Wed, 05 Jul 2023 13:34:07 +0200
+
pd-bassemu (0.3-10) unstable; urgency=medium
* Modernize 'licensecheck' target
diff --git a/debian/control b/debian/control
index bb91a11..5f9530b 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,8 @@ Uploaders:
IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>,
Build-Depends:
debhelper-compat (= 13),
- puredata-dev | puredata,
-Standards-Version: 4.6.1
+ dh-sequence-pd-lib-builder,
+Standards-Version: 4.6.2
Rules-Requires-Root: no
Homepage: https://puredata.info
Vcs-Git: https://salsa.debian.org/multimedia-team/pd/pd-bassemu.git
@@ -16,9 +16,13 @@ Vcs-Browser: https://salsa.debian.org/multimedia-team/pd/pd-bassemu
Package: pd-bassemu
Architecture: any
Depends:
- puredata-core | pd,
${misc:Depends},
+ ${puredata:Depends},
${shlibs:Depends},
+Recommends:
+ ${puredata:Recommends},
+Suggests:
+ ${puredata:Suggests},
Description: Pd object for transistor bass emulation
bassemu~ is an object that simulates a transistor-based electronic
synthesizer. This serves as a emulation of an analogue bass synth. It
diff --git a/debian/patches/auto-gitignore b/debian/patches/auto-gitignore
index d59ea67..c892008 100644
--- a/debian/patches/auto-gitignore
+++ b/debian/patches/auto-gitignore
@@ -4,7 +4,7 @@ The Debian packaging git branch contains these updates to the upstream
.gitignore file(s). This patch is autogenerated, to provide these
updates to users of the official Debian archive view of the package.
-[dgit (10.1) update-gitignore]
+[dgit (11.0) update-gitignore]
---
diff --git a/.gitignore b/.gitignore
new file mode 100644
diff --git a/debian/patches/makefile_update_for_kfreebsd_and_hurd b/debian/patches/makefile_update_for_kfreebsd_and_hurd
deleted file mode 100644
index 0feb98c..0000000
--- a/debian/patches/makefile_update_for_kfreebsd_and_hurd
+++ /dev/null
@@ -1,91 +0,0 @@
-Description: updated Makefile to build on kFreeBSD and Hurd
- This patch takes the upstream template Makefile with new code for handling
- building using kFreeBSD and Hurd kernels. This Makefile is already included
- in the upstream SVN repository, but there is no new release yet.
-
-Author: Hans-Christoph Steiner <hans@eds.org>
-Bug-Debian: http://bugs.debian.org/605821
-Forwarded: not-needed
-Reviewed-By: Hans-Christoph Steiner <hans@eds.org>
-Last-Update: <2010-12-19>
-
---- pd-bassemu-0.3.orig/Makefile
-+++ pd-bassemu-0.3/Makefile
-@@ -1,4 +1,4 @@
--## Pd library template version 1.0.4
-+## Pd library template version 1.0.6
- # For instructions on how to use this template, see:
- # http://puredata.info/docs/developer/MakefileTemplate
- LIBRARY_NAME = bassemu~
-@@ -31,7 +31,8 @@ EXTRA_DIST = miniseq.pd Makefile.nt
- #
- #------------------------------------------------------------------------------#
-
--CFLAGS = -DPD -I"$(PD_INCLUDE)" -Wall -W -g
-+# -I"$(PD_INCLUDE)/pd" supports the header location for 0.43
-+CFLAGS = -I"$(PD_INCLUDE)/pd" -Wall -W -g
- LDFLAGS =
- LIBS =
-
-@@ -44,7 +45,7 @@ LIBS =
- # get library version from meta file
- LIBRARY_VERSION = $(shell sed -n 's|^\#X text [0-9][0-9]* [0-9][0-9]* VERSION \(.*\);|\1|p' $(LIBRARY_NAME)-meta.pd)
-
--CFLAGS += -DVERSION='"$(LIBRARY_VERSION)"'
-+CFLAGS += -DPD -DVERSION='"$(LIBRARY_VERSION)"'
-
- PD_INCLUDE = $(PD_PATH)/include
- # where to install the library, overridden below depending on platform
-@@ -121,6 +122,34 @@ ifeq ($(UNAME),Linux)
- STRIP = strip --strip-unneeded -R .note -R .comment
- DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
- endif
-+ifeq ($(UNAME),GNU)
-+ # GNU/Hurd, should work like GNU/Linux for basically all externals
-+ CPU := $(shell uname -m)
-+ SOURCES += $(SOURCES_linux)
-+ EXTENSION = pd_linux
-+ OS = linux
-+ PD_PATH = /usr
-+ OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
-+ CFLAGS += -fPIC
-+ LDFLAGS += -Wl,--export-dynamic -shared -fPIC
-+ LIBS += -lc
-+ STRIP = strip --strip-unneeded -R .note -R .comment
-+ DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
-+endif
-+ifeq ($(UNAME),GNU/kFreeBSD)
-+ # Debian GNU/kFreeBSD, should work like GNU/Linux for basically all externals
-+ CPU := $(shell uname -m)
-+ SOURCES += $(SOURCES_linux)
-+ EXTENSION = pd_linux
-+ OS = linux
-+ PD_PATH = /usr
-+ OPT_CFLAGS = -O6 -funroll-loops -fomit-frame-pointer
-+ CFLAGS += -fPIC
-+ LDFLAGS += -Wl,--export-dynamic -shared -fPIC
-+ LIBS += -lc
-+ STRIP = strip --strip-unneeded -R .note -R .comment
-+ DISTBINDIR=$(DISTDIR)-$(OS)-$(shell uname -m)
-+endif
- ifeq (CYGWIN,$(findstring CYGWIN,$(UNAME)))
- CPU := $(shell uname -m)
- SOURCES += $(SOURCES_cygwin)
-@@ -140,7 +169,7 @@ ifeq (MINGW,$(findstring MINGW,$(UNAME))
- EXTENSION = dll
- OS = windows
- PD_PATH = $(shell cd "$(PROGRAMFILES)"/pd && pwd)
-- OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer -march=i686 -mtune=pentium4
-+ OPT_CFLAGS = -O3 -funroll-loops -fomit-frame-pointer
- CFLAGS += -mms-bitfields
- LDFLAGS += -s -shared -Wl,--enable-auto-import
- LIBS += -L"$(PD_PATH)/src" -L"$(PD_PATH)/bin" -L"$(PD_PATH)/obj" -lpd -lwsock32 -lkernel32 -luser32 -lgdi32
-@@ -149,7 +178,7 @@ ifeq (MINGW,$(findstring MINGW,$(UNAME))
- endif
-
- # in case somebody manually set the HELPPATCHES above
--HELPPATCHES ?= $(SOURCES:.c=-help.pd) $(PDOBJECTS:.c=-help.pd)
-+HELPPATCHES ?= $(SOURCES:.c=-help.pd) $(PDOBJECTS:.pd=-help.pd)
-
- CFLAGS += $(OPT_CFLAGS)
-
diff --git a/debian/patches/pd-lib-builder.patch b/debian/patches/pd-lib-builder.patch
new file mode 100644
index 0000000..21f2ae3
--- /dev/null
+++ b/debian/patches/pd-lib-builder.patch
@@ -0,0 +1,11 @@
+Description: Override buildsystem with pd-lib-builder
+Author: IOhannes m zmölnig
+Origin: Debian
+Forwarded: no
+Last-Update: 2023-07-03
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- /dev/null
++++ pd-arraysize/GNUmakefile
+@@ -0,0 +1 @@
++include debian/Makefile.plb
diff --git a/debian/patches/series b/debian/patches/series
index 24db7d3..ede2383 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,2 @@
-makefile_update_for_kfreebsd_and_hurd
+pd-lib-builder.patch
auto-gitignore
diff --git a/debian/rules b/debian/rules
index e63042d..3defa95 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,7 @@
#!/usr/bin/make -f
-pkglibdir = /usr/lib/pd/extra
-
%:
- dh $@
-
-override_dh_auto_build:
- dh_auto_build -- \
- CFLAGS="-DPD -fPIC $(CFLAGS) $(CPPFLAGS) -I/usr/include/pd" \
- LDFLAGS="-Wl,--export-dynamic -shared -fPIC $(LDFLAGS)" \
- $(empty)
-
-override_dh_auto_install:
- dh_auto_install -- prefix=/usr pkglibdir=$(pkglibdir) STRIP=true
-# replace license file with link to the Debian license file
- rm -f -- $(CURDIR)/debian/*/$(pkglibdir)/*/LICENSE.txt
+ dh $@ --buildsystem=pd_lib_builder
DEB_COPYRIGHT_CHECK_IGNORE_REGEX = \
debian/.*