summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDebian Multimedia Maintainers <debian-multimedia@lists.debian.org>2024-03-16 23:35:42 +0100
committerIOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>2024-03-16 23:35:42 +0100
commit1b9f8fcca4e3a85b6ebb056782a660f58941570b (patch)
tree35b2fb43d56fa07a331f9ed5853a8547ff53547a
parent9b3704776b884e44afc46f8f31932f51563fb68b (diff)
Allow overriding pkg-config for crossbuilding
Origin: upstream Applied-Upstream: 677c46a0f24abe14ac848cfbb7d9b25ad4d121cb Last-Update: 2022-11-23 Last-Update: 2022-11-23 Gbp-Pq: Name crossbuild.patch
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index b08a2d8..04fca01 100644
--- a/Makefile
+++ b/Makefile
@@ -10,8 +10,9 @@ ldlibs =
###########################################################
# Tcl stuff
-TCL_CFLAGS=$(shell pkg-config --cflags tcl)
-TCL_LIBS=$(shell pkg-config --libs tcl)
+PKG_CONFIG=pkg-config
+TCL_CFLAGS=$(shell $(PKG_CONFIG) --cflags tcl)
+TCL_LIBS=$(shell $(PKG_CONFIG) --libs tcl)
## Dawrin
# TCL_CFLAGS = -I/Library/Frameworks/Tcl.framework/Headers