summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog10
-rw-r--r--debian/tests/rapper.sh9
2 files changed, 19 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 1c8e431..f93d466 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+php-easyrdf (1.0.0-3) unstable; urgency=medium
+
+ * Team upload
+
+ [ Marco Villegas ]
+ * Check server output on rapper smoke test.
+ Closes: #1001593.
+
+ -- Paul Gevers <elbrus@debian.org> Sun, 04 Sep 2022 21:35:19 +0200
+
php-easyrdf (1.0.0-2) unstable; urgency=medium
* Change gbp to use debian/bullseye for the maintenance branch
diff --git a/debian/tests/rapper.sh b/debian/tests/rapper.sh
index b86157b..a6e8816 100644
--- a/debian/tests/rapper.sh
+++ b/debian/tests/rapper.sh
@@ -6,6 +6,15 @@ set -e
php --server localhost:10101 --docroot debian/tests/data &
SERVER_PID=$!
+set +e
+curl --fail --silent --output /dev/null http://localhost:10101/foaf.rdf
+if [ $? -ne 0 ]
+then
+ # Likely 22, the server may not be ready, give it a bit of time.
+ sleep 2
+fi
+set -e
+
# A graphviz source file can be created.
php debian/tests/rapper.php > sample.dot