summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <emollier@debian.org>2023-08-15 10:45:37 +0200
committerÉtienne Mollier <emollier@debian.org>2023-08-15 10:45:37 +0200
commit09e8a8c310c7a91304e8dafd51214c94299d707b (patch)
tree7ff1bd8d83e5246854b130489e2c79dbd8785b74
parent43cd2a6148e8a8b14f9a8a65a1f020fa03cc8a2e (diff)
fix infinite loop with gcc 13
Bug: https://github.com/FePhyFoFum/phyx/issues/178 Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1037817 Last-Update: 2023-08-12 Since gcc 13, the superdouble operation goes in infinite loop. Disabline compilation with -ffast-math resolves the issue. Last-Update: 2023-08-12 Gbp-Pq: Name deoptimize.patch
-rw-r--r--src/Makefile.in2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 28681ff..7fb61dd 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -35,8 +35,6 @@ ifneq "$(CXX)" "icc"
OPT_FLAGS += -ftree-vectorize
ifneq ($(filter @host_cpu@,i386 i486 i586 i686),)
OPT_FLAGS += -ffloat-store
- else
- OPT_FLAGS += -ffast-math
endif
endif