summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <emollier@debian.org>2023-08-12 23:59:58 +0200
committerÉtienne Mollier <emollier@debian.org>2023-08-12 23:59:58 +0200
commit203d3d14a39bccf797ae712cde57ae73283ee1bd (patch)
tree2e18dfeccb0634cc670bd5af7e10c4c690ba26bb
parenta0f04f740f597fae2c274f0d89a95b58b28c0445 (diff)
deoptimize.patch: new: fix ftbfs with gcc-13.
This disables building phyx with -ffast-math. Closes: #1037817
-rw-r--r--debian/patches/deoptimize.patch20
-rw-r--r--debian/patches/series1
2 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/deoptimize.patch b/debian/patches/deoptimize.patch
new file mode 100644
index 0000000..4ad44ad
--- /dev/null
+++ b/debian/patches/deoptimize.patch
@@ -0,0 +1,20 @@
+Description: fix infinite loop with gcc 13
+ Since gcc 13, the superdouble operation goes in infinite loop.
+ Disabline compilation with -ffast-math resolves the issue.
+Author: Étienne Mollier <emollier@debian.org>
+Bug: https://github.com/FePhyFoFum/phyx/issues/178
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1037817
+Last-Update: 2023-08-12
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- phyx.orig/src/Makefile.in
++++ phyx/src/Makefile.in
+@@ -35,8 +35,6 @@
+ OPT_FLAGS += -ftree-vectorize
+ ifneq ($(filter @host_cpu@,i386 i486 i586 i686),)
+ OPT_FLAGS += -ffloat-store
+- else
+- OPT_FLAGS += -ffast-math
+ endif
+ endif
+
diff --git a/debian/patches/series b/debian/patches/series
index ecf3f9a..1ae81ab 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
build-more-programs.patch
i386.patch
+deoptimize.patch