summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorÉtienne Mollier <emollier@debian.org>2023-08-13 00:01:53 +0200
committerÉtienne Mollier <emollier@debian.org>2023-08-13 00:01:53 +0200
commitdd2fac0d32194e99e3bdbe45217d34e6b7e49e94 (patch)
tree19baa4e73aa5764a0c7af5d36e435167287bae32
parent78ec9024338b1924d11be73a43c853e2522f7ced (diff)
fix "nan" test failures on i386 caused by -ffast-math
Bug: https://github.com/FePhyFoFum/phyx/issues/145#issuecomment-824866619 Last-Update: 2022-04-14 Last-Update: 2022-04-14 Gbp-Pq: Name i386.patch
-rw-r--r--src/Makefile.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.in b/src/Makefile.in
index 067423f..28681ff 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -32,7 +32,12 @@ ifeq "$(HOMP)" "Y"
endif
ifneq "$(CXX)" "icc"
- OPT_FLAGS += -ffast-math -ftree-vectorize
+ OPT_FLAGS += -ftree-vectorize
+ ifneq ($(filter @host_cpu@,i386 i486 i586 i686),)
+ OPT_FLAGS += -ffloat-store
+ else
+ OPT_FLAGS += -ffast-math
+ endif
endif
NLOPT_PROGRAMS :=