summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4d44a7c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+include /usr/share/ocaml/ocamlvars.mk
+
+%:
+ dh $@ --with ocaml
+
+override_dh_auto_build:
+ dune build -p ppx_expect
+
+override_dh_auto_install:
+ dune install --destdir=$(CURDIR)/debian/tmp --prefix=/usr --libdir=$(OCAML_STDLIB_DIR)
+ find $(CURDIR)/debian/tmp -name LICENSE.md -delete
+
+override_dh_auto_test:
+ # do nothing!