summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Röhling <roehling@debian.org>2023-09-16 11:19:16 +0200
committerTimo Röhling <roehling@debian.org>2023-09-16 11:19:16 +0200
commit16e7a94913cbbdc7a3126b2bc424d2ef055cf5f2 (patch)
tree227e8d04dbddc6936757d605a4d48af03c5246a2
parentadbcdc6504245a7d40cc8fdb9bbdc36c81d546d3 (diff)
Refresh patches (no functional changes)
-rw-r--r--debian/patches/0001-Remove-check-for-unneeded-development-headers.patch12
-rw-r--r--debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch8
-rw-r--r--debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch22
-rw-r--r--debian/patches/0004-Use-python3-in-doctests.patch8
4 files changed, 29 insertions, 21 deletions
diff --git a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
index f37a318..fa308f7 100644
--- a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
+++ b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
@@ -7,12 +7,12 @@ Subject: Remove check for unneeded development headers
1 file changed, 6 deletions(-)
diff --git a/setup.py b/setup.py
-index 8239ac3..8b4f215 100755
+index e6bb612..15695f9 100755
--- a/setup.py
+++ b/setup.py
-@@ -70,12 +70,6 @@ install_requires = ['paramiko>=1.15.2',
- if platform.python_version_tuple()[0] == '2':
- install_requires += ['pathlib2']
+@@ -54,12 +54,6 @@ if sys.version_info < (3, 4):
+ sys.argv.remove('--user')
+
-# Check that the user has installed the Python development headers
-PythonH = os.path.join(get_python_inc(), 'Python.h')
@@ -21,5 +21,5 @@ index 8239ac3..8b4f215 100755
- print("$ apt-get install python-dev", file=sys.stderr)
- sys.exit(-1)
- # Convert README.md to reStructuredText for PyPI
- long_description = ''
+ setup(
+ version = '4.11.0',
diff --git a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
index e9da30f..154a657 100644
--- a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
+++ b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
@@ -7,10 +7,10 @@ Subject: Do not pollute /usr/bin with random scripts
1 file changed, 18 deletions(-)
diff --git a/setup.py b/setup.py
-index 8b4f215..364505c 100755
+index 15695f9..bfe7e19 100755
--- a/setup.py
+++ b/setup.py
-@@ -26,24 +26,6 @@ for scheme in INSTALL_SCHEMES.values():
+@@ -25,24 +25,6 @@ for scheme in INSTALL_SCHEMES.values():
console_scripts = ['pwn=pwnlib.commandline.main:main']
@@ -33,5 +33,5 @@ index 8b4f215..364505c 100755
- if not flag:
- console_scripts.append(script)
- install_requires = ['paramiko>=1.15.2',
- 'mako>=1.0.0',
+ compat = {}
+ if sys.version_info < (3, 4):
diff --git a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
index 4514bfd..f8f9353 100644
--- a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
+++ b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
@@ -3,17 +3,25 @@ Date: Mon, 11 Apr 2022 12:49:14 +0200
Subject: Do not install documentation to /usr/lib/python3
---
- setup.py | 3 ---
- 1 file changed, 3 deletions(-)
+ setup.py | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/setup.py b/setup.py
-index 364505c..0d23755 100755
+index bfe7e19..5421041 100755
--- a/setup.py
+++ b/setup.py
-@@ -66,9 +66,6 @@ setup(
- python_requires = '>=2.7',
- packages = find_packages(),
- version = '4.10.0',
+@@ -11,6 +11,7 @@ from distutils.command.install import INSTALL_SCHEMES
+ from distutils.sysconfig import get_python_inc
+ from distutils.util import convert_path
+
++from setuptools import find_packages
+ from setuptools import setup
+
+ # Get all template files
+@@ -39,9 +40,6 @@ if sys.version_info < (3, 4):
+
+ setup(
+ version = '4.11.0',
- data_files = [('pwntools-doc',
- glob.glob('*.md') + glob.glob('*.txt')),
- ],
diff --git a/debian/patches/0004-Use-python3-in-doctests.patch b/debian/patches/0004-Use-python3-in-doctests.patch
index 9484f0c..6de9fee 100644
--- a/debian/patches/0004-Use-python3-in-doctests.patch
+++ b/debian/patches/0004-Use-python3-in-doctests.patch
@@ -45,7 +45,7 @@ index 8770ade..1449994 100644
>>> p.recv()
b'XXX'
diff --git a/pwnlib/tubes/ssh.py b/pwnlib/tubes/ssh.py
-index cd06f34..a457c10 100644
+index adda422..6aee6e0 100644
--- a/pwnlib/tubes/ssh.py
+++ b/pwnlib/tubes/ssh.py
@@ -384,7 +384,7 @@ class ssh_process(ssh_channel):
@@ -57,10 +57,10 @@ index cd06f34..a457c10 100644
>>> hex(p.getenv('PATH')) # doctest: +ELLIPSIS
'0x...'
"""
-@@ -843,7 +843,7 @@ class ssh(Timeout, Logger):
- True
- >>> s.process(['pwd'], cwd='/tmp').recvall()
+@@ -846,7 +846,7 @@ class ssh(Timeout, Logger):
b'/tmp\n'
+ >>> io.cwd
+ '/tmp'
- >>> p = s.process(['python','-c','import os; os.write(1, os.read(2, 1024))'], stderr=0)
+ >>> p = s.process(['python3','-c','import os; os.write(1, os.read(2, 1024))'], stderr=0)
>>> p.send(b'hello')