summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Röhling <roehling@debian.org>2022-09-29 21:10:20 +0200
committerTimo Röhling <roehling@debian.org>2022-09-29 21:10:20 +0200
commit315fe97f0cadda09023c81e6787968a20da51c86 (patch)
tree62d1d44e7074d531a5237840f7e09b6af43b8385
parent9e8c68539a8f566dfbd82a244dac447869d0defc (diff)
Refresh patches
Gbp-Dch: ignore
-rw-r--r--debian/patches/0001-Remove-check-for-unneeded-development-headers.patch2
-rw-r--r--debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch2
-rw-r--r--debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch4
-rw-r--r--debian/patches/0005-Use-python3-in-doctests.patch6
4 files changed, 7 insertions, 7 deletions
diff --git a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
index 6698c60..8202572 100644
--- a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
+++ b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
@@ -7,7 +7,7 @@ Subject: Remove check for unneeded development headers
1 file changed, 6 deletions(-)
diff --git a/setup.py b/setup.py
-index f925051..5c8d03b 100755
+index ab1c9b2..5a3d01d 100755
--- a/setup.py
+++ b/setup.py
@@ -70,12 +70,6 @@ install_requires = ['paramiko>=1.15.2',
diff --git a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
index be4c04b..d61d9cf 100644
--- a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
+++ b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
@@ -7,7 +7,7 @@ Subject: Do not pollute /usr/bin with random scripts
1 file changed, 18 deletions(-)
diff --git a/setup.py b/setup.py
-index 5c8d03b..c434412 100755
+index 5a3d01d..032b333 100755
--- a/setup.py
+++ b/setup.py
@@ -26,24 +26,6 @@ for scheme in INSTALL_SCHEMES.values():
diff --git a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
index 63bf5d5..88183a6 100644
--- a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
+++ b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
@@ -7,13 +7,13 @@ Subject: Do not install documentation to /usr/lib/python3
1 file changed, 3 deletions(-)
diff --git a/setup.py b/setup.py
-index c434412..e54c980 100755
+index 032b333..3114723 100755
--- a/setup.py
+++ b/setup.py
@@ -66,9 +66,6 @@ setup(
python_requires = '>=2.7',
packages = find_packages(),
- version = '4.8.0',
+ version = '4.9.0beta0',
- data_files = [('pwntools-doc',
- glob.glob('*.md') + glob.glob('*.txt')),
- ],
diff --git a/debian/patches/0005-Use-python3-in-doctests.patch b/debian/patches/0005-Use-python3-in-doctests.patch
index 583be75..d54fdce 100644
--- a/debian/patches/0005-Use-python3-in-doctests.patch
+++ b/debian/patches/0005-Use-python3-in-doctests.patch
@@ -8,7 +8,7 @@ Subject: Use python3 in doctests
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/pwnlib/tubes/process.py b/pwnlib/tubes/process.py
-index edf17fd..6bce213 100644
+index f42bae2..3efa6ba 100644
--- a/pwnlib/tubes/process.py
+++ b/pwnlib/tubes/process.py
@@ -117,7 +117,7 @@ class process(tube):
@@ -45,7 +45,7 @@ index edf17fd..6bce213 100644
>>> p.recv()
b'XXX'
diff --git a/pwnlib/tubes/ssh.py b/pwnlib/tubes/ssh.py
-index 0fcba0c..a0c12cd 100644
+index eab27a5..1b5176e 100644
--- a/pwnlib/tubes/ssh.py
+++ b/pwnlib/tubes/ssh.py
@@ -384,7 +384,7 @@ class ssh_process(ssh_channel):
@@ -57,7 +57,7 @@ index 0fcba0c..a0c12cd 100644
>>> hex(p.getenv('PATH')) # doctest: +ELLIPSIS
'0x...'
"""
-@@ -832,7 +832,7 @@ class ssh(Timeout, Logger):
+@@ -843,7 +843,7 @@ class ssh(Timeout, Logger):
True
>>> s.process(['pwd'], cwd='/tmp').recvall()
b'/tmp\n'