summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Röhling <roehling@debian.org>2023-06-12 13:34:41 +0200
committerTimo Röhling <roehling@debian.org>2023-06-12 13:34:41 +0200
commit4417dde39ee675bd7c0efd82014e23796688bed6 (patch)
tree0e611d8d7a092b1f88fadaa0d3e4e3efdd8f13fb
parent18587ec41c6c2e9ba888795b7fbf2ade862618d2 (diff)
Refresh patches
-rw-r--r--debian/patches/0001-Remove-check-for-unneeded-development-headers.patch2
-rw-r--r--debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch2
-rw-r--r--debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch4
-rw-r--r--debian/patches/0004-Use-python3-in-doctests.patch4
4 files changed, 6 insertions, 6 deletions
diff --git a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
index b3ca15b..f37a318 100644
--- a/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
+++ b/debian/patches/0001-Remove-check-for-unneeded-development-headers.patch
@@ -7,7 +7,7 @@ Subject: Remove check for unneeded development headers
1 file changed, 6 deletions(-)
diff --git a/setup.py b/setup.py
-index cc29bc8..1f515e7 100755
+index 8239ac3..8b4f215 100755
--- a/setup.py
+++ b/setup.py
@@ -70,12 +70,6 @@ install_requires = ['paramiko>=1.15.2',
diff --git a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
index b76adb6..e9da30f 100644
--- a/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
+++ b/debian/patches/0002-Do-not-pollute-usr-bin-with-random-scripts.patch
@@ -7,7 +7,7 @@ Subject: Do not pollute /usr/bin with random scripts
1 file changed, 18 deletions(-)
diff --git a/setup.py b/setup.py
-index 1f515e7..d0c1842 100755
+index 8b4f215..364505c 100755
--- a/setup.py
+++ b/setup.py
@@ -26,24 +26,6 @@ for scheme in INSTALL_SCHEMES.values():
diff --git a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
index fd124cd..4514bfd 100644
--- a/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
+++ b/debian/patches/0003-Do-not-install-documentation-to-usr-lib-python3.patch
@@ -7,13 +7,13 @@ Subject: Do not install documentation to /usr/lib/python3
1 file changed, 3 deletions(-)
diff --git a/setup.py b/setup.py
-index d0c1842..2bfb093 100755
+index 364505c..0d23755 100755
--- a/setup.py
+++ b/setup.py
@@ -66,9 +66,6 @@ setup(
python_requires = '>=2.7',
packages = find_packages(),
- version = '4.9.0',
+ version = '4.10.0',
- data_files = [('pwntools-doc',
- glob.glob('*.md') + glob.glob('*.txt')),
- ],
diff --git a/debian/patches/0004-Use-python3-in-doctests.patch b/debian/patches/0004-Use-python3-in-doctests.patch
index d54fdce..9484f0c 100644
--- a/debian/patches/0004-Use-python3-in-doctests.patch
+++ b/debian/patches/0004-Use-python3-in-doctests.patch
@@ -8,7 +8,7 @@ Subject: Use python3 in doctests
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/pwnlib/tubes/process.py b/pwnlib/tubes/process.py
-index f42bae2..3efa6ba 100644
+index 8770ade..1449994 100644
--- a/pwnlib/tubes/process.py
+++ b/pwnlib/tubes/process.py
@@ -117,7 +117,7 @@ class process(tube):
@@ -45,7 +45,7 @@ index f42bae2..3efa6ba 100644
>>> p.recv()
b'XXX'
diff --git a/pwnlib/tubes/ssh.py b/pwnlib/tubes/ssh.py
-index eab27a5..1b5176e 100644
+index cd06f34..a457c10 100644
--- a/pwnlib/tubes/ssh.py
+++ b/pwnlib/tubes/ssh.py
@@ -384,7 +384,7 @@ class ssh_process(ssh_channel):