summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Röhling <roehling@debian.org>2022-04-11 12:04:19 +0200
committerTimo Röhling <roehling@debian.org>2023-11-15 17:55:27 +0100
commit8b07b6172ea68386bfa0fa345ce75690f3b48afb (patch)
treecbb18630086ed0408abc5e0798911a7f4777ee05
parent1719d16eaacee2f67faa54523043bb778364037e (diff)
Do not pollute /usr/bin with random scripts
Gbp-Pq: Name 0002-Do-not-pollute-usr-bin-with-random-scripts.patch
-rwxr-xr-xsetup.py18
1 files changed, 0 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 77afde4..9c53854 100755
--- a/setup.py
+++ b/setup.py
@@ -23,24 +23,6 @@ for scheme in INSTALL_SCHEMES.values():
console_scripts = ['pwn=pwnlib.commandline.main:main']
-# Find all of the ancillary console scripts
-# We have a magic flag --include-all-scripts
-flag = '--only-use-pwn-command'
-if flag in sys.argv:
- sys.argv.remove(flag)
-else:
- flag = False
-
-for filename in glob.glob('pwnlib/commandline/*'):
- filename = os.path.basename(filename)
- filename, ext = os.path.splitext(filename)
-
- if ext != '.py' or '__init__' in filename:
- continue
-
- script = '%s=pwnlib.commandline.common:main' % filename
- if not flag:
- console_scripts.append(script)
compat = {}
if sys.version_info < (3, 4):