summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 78d315e..5175530 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -55,6 +55,8 @@ dependencies = [
"rpyc",
"colored_traceback",
"pathlib2; python_version < '3.4'",
+ "unix-ar; python_version >= '3'",
+ "zstandard",
]
[project.urls]
@@ -69,3 +71,18 @@ include-package-data = false
[tool.setuptools.packages.find]
namespaces = false
+
+[tool.coverage.run]
+branch = true
+parallel = true
+concurrency = ["thread", "multiprocessing"]
+omit = [
+ "*/constants/*",
+]
+source = [
+ "pwn",
+ "pwnlib",
+ "~/.cache/.pwntools-cache-2.7/",
+ "~/.cache/.pwntools-cache-3.10/",
+]
+disable_warnings = ["module-not-imported"]