summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 65cb5c3..88ce6c2 100755
--- a/setup.py
+++ b/setup.py
@@ -44,13 +44,15 @@ for filename in glob.glob('pwnlib/commandline/*'):
compat = {}
if sys.version_info < (3, 4):
+ import site
+
import toml
project = toml.load('pyproject.toml')['project']
compat['packages'] = find_packages()
compat['install_requires'] = project['dependencies']
compat['name'] = project['name']
- if '--user' in sys.argv:
- sys.argv.remove('--user')
+ # https://github.com/pypa/pip/issues/7953
+ site.ENABLE_USER_SITE = "--user" in sys.argv[1:]
# Check that the user has installed the Python development headers
@@ -61,7 +63,7 @@ if not os.path.exists(PythonH):
sys.exit(-1)
setup(
- version = '4.11.1',
+ version = '4.12.0',
data_files = [('pwntools-doc',
glob.glob('*.md') + glob.glob('*.txt')),
],